
20 Tutorials

This chapter presents information and sample problems to explore some of Thermal Desk-
top’s features. Before beginning the tutorials, AutoCAD®, Thermal Desktop, and SINDA/FLU-
INT must be installed. Refer to the AutoCAD and Thermal Desktop installation instructions to 
complete these installations if the software is not already installed.

Tutorial files may be found in the \Tutorials\Thermal Desktop subdirectory which is located in 
the Thermal Desktop installation directory (usually C:\Program Files\Cullimore And 
Ring\Thermal Desktop). The \Tutorials\Thermal Desktop subdirectory includes additional 
subdirectories, one for each of the tutorials covered in the subsequent sections of this chap-
ter. For some of the tutorials, a completed tutorial file is included in the \completed direc-
tory.

It is recommended that the \Tutorials\Thermal Desktop directory be copied to the user’s own 
working area before beginning the tutorials. This ensures a copy of the original tutorial files 
will be available for use by other users at a later time.

The tutorials attempt to introduce a variety of concepts. Most often there is more than one 
way to accomplish the “task” of a tutorial. Different techniques are shown in an attempt to 
expose the user to the variety of features present in Thermal Desktop. In particular, there are 
many ways of selecting objects, and both noun-verb (object selection followed by a com-
mand) and verb-noun (a command followed by object selection) order is supported for most 
commands. Identical tasks may be performed differently to illustrate a particular feature.

It is also strongly suggested that each new user take the time to work through each of the 
tutorials (in this chapter as well as the other tutorial chapters: 21 RadCAD® Tutorials and 22 
FloCAD® Tutorials). Although completing the tutorials requires time, doing so will provide 
the user with enough knowledge and skills to allow the user to quickly become effective and 
efficient while working in Thermal Desktop.
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Tutorials
There are eleven tutorials in this chapter, as follows:

■ 20.1 Getting Started
■ 20.2 Setting Up a Template Drawing
■ 20.3 Model Browser Example
■ 20.4 Circuit Board Conduction Example
■ 20.5 Beer Can Example
■ 20.6 Conduction and Radiation Using Finite Elements
■ 20.7 Mapping Temperatures From a Coarse Thermal Model to a Detailed NASTRAN 

Model
■ 20.8 Contactor Example
■ 20.9 Parameterizing for a Common Input
■ 20.10 Dynamic SINDA Example

Functionality in the tutorials reflects the most recent version of Thermal Desktop and Auto-
CAD. Every effort has been made to present the user with the exact system prompts, mes-
sages and commands, and dialog boxes the user will see when using Thermal Desktop. 
Please note that occasionally minor changes may be made between application releases and, 
as such, small changes to wording in such items may be experienced. The “how to” function-
ality will not change.

Most of the tutorials are written in a two-column format. The left column provides specific 
instructions and the right column provides a general description of the steps, provides 
example views of the graphics area, and sometimes provides background information and 
alternative methods for accomplishing the steps. Reading through the information in the 
right column before completing the steps on the left will be much more beneficial to the user 
than autonomously completing the steps in the left column.
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20.2 Setting Up a Template Drawing

Prerequisites:

■ 20.1.1 Starting AutoCAD for the First Time

A template is something that can be used as a pattern for future projects. In Thermal Desk-
top, a template drawing file can be created and used as a foundation for creating new Ther-
mal Desktop drawings. When creating a template it is important to consider how the 
template will be used, if the template will be used by only one user or by more than one, 
what preferences should be associated with the template and other such considerations.

In this tutorial, a template drawing file (file extension DWG) will be created. The template will 
be used in other tutorials and may be used as a permanent template for use in future thermal 
analysis tasks. Creating and then using a template drawing starts a new analysis with an 
environment set to pre-determined preferences, helping to keep drawings consistent and 
easy to use.

Before beginning a new thermal analysis task, copy the template to a directory chosen to 
store the work for that particular task or project. Once a copy is made, rename the copied 
template drawing to a meaningful name related to the thermal task or project. Then start 
Thermal Desktop by double-clicking on the renamed drawing file. Thermal Desktop will start 
with the preferences saved in the template, and the current working directory will be set to 
the directory which contains the drawing file. All database files created by Thermal Desktop 
for view factors, radiation conductors, and orbital heating rates will be placed in this working 
directory.

Important: If Thermal Desktop is not launched using the drawing file for the task and 
instead is started from the AutoCAD Icon, the current working directory will be the user’s 
Documents directory. This is not recommended, since multiple thermal analysis tasks 
may overwrite each other’s database files.
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The following exercise creates a template file with preferences set to be convenient for 
working with Thermal Desktop. The user is encouraged to experiment with the available 
options as a means to discover which settings are compatible to each individual’s work style. 

Setting Up a Template Thermal Desktop Drawing File

Important:  The process described below should only be used when creating a tem-
plate. In future tutorials or modeling when an existing model is not available, a tem-
plate drawing file should be copied to the desired folder, renamed and the file icon 
double-clicked to start Thermal Desktop.

1. From the Windows desktop go to Start > All Programs and look for AutoDesk. Follow 
that path to the version of AutoCAD installed, and then follow that to the executable 
(i.e. Start > All Programs > AutoDesk > AutoCAD 20xx - English > AutoCAD 20xx - 
English).

Important: If it is not possible to complete the Getting Started drawing (drawing1.dwg) 
in the same sitting, exit Thermal Desktop (File > Exit) and respond No when prompted 
to save the drawing. To save the drawing, perform a Save As and change to a directory 
other than the initial system installation directory.
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The AutoCAD window appears.

2. If the window looks like the image 
above, select Start Drawing under Get-
ting Started to the upper left.
The window changes to a grid and the 
toolbars and ribbons become active.

3. View > Visual Styles > 2D Wireframe to 
be consistent with the images in this 
tutorial.

4. Select File > Save As.
5. Change the name of Drawing1.dwg to 

thermal.dwg in the \Tutorials\Thermal 
Desktop\template directory.

6. Select Save.
The drawing area title bar is updated 
with the new name of the drawing, ther-
mal.

Be sure to save the files in your copy of 
the tutorials directory.
This save occurs before any Thermal 
Desktop commands are issued, therefore, 
at this point the file is strictly an AutoCAD 
file.

Note: If your models may be opened 
with older versions of AutoCAD, 
choose the version predates the 
oldest version that may be used. 
Thermal Desktop 6.1 works with 
AutoCAD versions 2015 through 
2019.

Setting Up a Template Thermal Desktop Drawing File
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7. Select Thermal > Utilities > Reset Ther-
mal Desktop Interface

8. In the Thermal Desktop User Interface 
dialog, verify that All Ribbons, Standard 
Toolbar, AutoCAD Menus, and Ribbon/
Thermal Desktop Forms Reduction are 
checked and other boxes are cleared.

The Thermal Desktop splash screen will 
be displayed when the first Thermal 
Desktop command is issued.
If the model had contained Thermal 
Desktop objects, the splash screen would 
have appeared upon opening the file.

9. Select View > 3D Views > SW Isometric.
Note the UCS icon changes to reflect the 
view.

Selecting View > 3D Views > SW Isometric 
here sets an isometric view parameter for 
the new template.

10. View the menu selection View > Display 
> UCS Icon> Origin. 

11. Confirm a check mark is displayed next 
to Origin. If a check mark is not visible, 
click Origin to select the option. Other-
wise click anywhere in the Thermal 
Desktop window or press <ESC>.

This step locates the User Coordinate 
System (UCS) display icon at the origin of 
the model, rather than in the lower left 
corner of the screen.
If the UCS origin is not in the display area, 
then the UCS will be displayed in the 
lower left corner.

Note: Depending upon the experience and preferences of the user, before saving the tem-
plate, the toolbars on the main window may be rearranged. The default arrangement 
of toolbars reduces the horizontal size of the viewport. The toolbars can be moved to 
the sides of the viewport to produce a viewport with a more square aspect ratio. Put 
the cursor in the border of a toolbar (not on an icon) and drag by holding the left 
mouse button down to the new desired location. As a toolbar is moved close to the 
sides of the screen, the toolbar will automatically dock to that side.

The Tools > Toolbars menu choice may also be used to turn specific toolbars on and 
off and to customize the icons in each toolbar. See the AutoCAD help for more details 
on customizing toolbars. It is helpful to remove infrequently used icons from some 
toolbars so that more toolbars may be displayed without taking up excessive screen 
space.

Setting Up a Template Thermal Desktop Drawing File
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As experience is gained with Thermal Desktop and some of the advanced options, create a 
new template file with different parameters such as Units and other property settings as 
desired. A user may find it useful to have a template for SI units, a template for English units, 
or possibly a template with certain default settings (2.6 Defaults).

Important: Remember to create a copy and rename the template before beginning design 
work to insure the template remains in its original state. If copying the template at the 
directory/file level by dragging the template file icon to the working directory, be sure to 
hold the <Ctrl> key down when dragging the template drawing file so that the template 
is copied, rather than moved.

12. Select File > Exit.
13. Select Yes to save changes to the tem-

plate file.
Thermal Desktop is closed.

Exiting AutoCAD without preceding the 
Exit command with a Save will bring up a 
dialog to save any changes.

14. Open the \Tutorials\Thermal Desktop\template folder and examine the contents.
The \completed folder is a folder included in many tutorials. It contains the dwg file 
the user would have after finishing the tutorial.
The thermal.bak file is a backup file generated by AutoCAD when a Save is per-
formed. This file is the previous version of the template.dwg file and can be used by 
changing the extension from .bak to .dwg in case the main file becomes corrupted.
The thermal.dwg file is a model file created by this tutorial. This file will be copied to 
other directories to use as a starting point for other tutorials and models.
The RcOptics.rco and TdThermo.tdp files are optical and thermophysical properties 
databases, respectively, that are automatically generated if they do not already exist, 
unless the model points to databases in specific file locations. 

Setting Up a Template Thermal Desktop Drawing File
20-39



20.3 Model Browser Example

What will be learned:

■ Overview of Thermal Desktop’s Model Browser
■ Using Model Browser for model troubleshooting and review
■ Assigning material properties
■ Basic use of Case Set Manager
■ Obtaining steady state and transient solutions in Thermal Desktop
■ Calculating heat flow between submodels
■ Using Model Browser to create XY plots against time for transient solutions

This tutorial demonstrates some of the capabilities of Thermal Desktop’s Model Browser. The 
example model for this tutorial is very simple but the capabilities extend very well to larger 
models.

Want to Learn More?  Refer to 2.4 Model Browser in the User’s
Manual for more information about the Model Browser. 

Model Browser Example 

1. Double click on the file ModelBrowser.dwg located in the Tutorials\Thermal 
Desktop\ModelBrowser folder.
Thermal Desktop opens with the ModelBrowser drawing on the screen. 

Thermal Desktop’s Model Browser can be used to view information about a model. A modeless 
window (can be resized and minimized) will list model data based on the type of data to be 
selected. The window is divided into two frames: the tree frame and the output frame. The 
default is to list by Submodel and ID.
The user may select the List By menu (within the Model Browser window) to see what types of 
objects are available for listing. 
The user can manipulate the AutoCAD graphics by simply making the graphics window active 
by clicking anywhere on the main AutoCAD window and then performing operations in that 
window.
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The user can determine what has been selected by looking in the output frame. The output 
frame will detail how many items have been selected and their type, the visibility state, the 
layers that the objects reside on, and additional data for the selected items.
As items in the tree frame of the Model Browser are selected, additional information about the 
selected item is displayed in the lower portion of the window. Single clicking on an item 
results in high-level information about the selected item being displayed below. Double click-
ing on an item in the tree frame of the Model Browser results in the expansion of the data tree 
and more detailed information being displayed.

2.  or Thermal > Model Browser.
The Model Browser window appears on 
the left side of the screen. 

Display the Model Browser.

The tree display is the upper half.

The output frame is the lower half.

3. Click on AAAA in the tree.
The display at the bottom of the Model 
Browser changes to show only the 
objects associated with AAAA.

As individual items, in this case submodel 
AAAA, are selected, the display area at the 
bottom of the Model Browser changes to 
reflect the components of the selected 
item.

AAAA includes:
5 objects selected
    2 TD/RC Nodes
    1 User Node
        1 boundary
    1 surface
    1 conductor

Model Browser Example  (Continued)
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4. Click on Submodel Node Tree located in 
the main view area of the Model 
Browser. 

When Submodel Node Tree is selected, all 
of the submodels that make up the model 
are selected, and displayed in the output 
frame.

20 objects selected
    11 TD/RC Nodes
    1 User Node
        1 boundary
    4 surfaces
    3 conductors
    1 heat load

Note: Use the scroll bar on the right of 
the output frame to view addi-
tional data.

5. Double click on submodel AAAA. The tree expands to show nodes, 1, 2, 
and 3 are associated with submodel 
AAAA.

An ‘A’, ‘B’, or ‘D’ in the icon for a node 
indicates that the node is Arithmetic, 
Boundary, or Diffusion, respectively. A 
circle indicates that the node definition is 
obtained from a surface, solid, or finite 
element.

6. Select node 1.

Note: Select by single clicking on the object 
with the left mouse button.

Node 1 consists of a User node and a sur-
face.

Model Browser Example  (Continued)
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7. Double click on node 1.

Note: Expand by double-clicking on the 
object name or clicking on the plus sign 
(+) to the left of the object.

The tree underneath node 1 is expanded 
and AAAA.1^::47 is displayed.

Items with the symbol :: (double colon) 
are graphical entities. The numbers after 
the :: are unique for each entity.

The ^ indicates that the node definition 
was originally defined by a surface, but 
the user overrode the definition.

8. Select AAAA.1^::47. Only the node is selected. The surface, 
that is below the node is not selected.
When an item with a :: is selected the 
objects below it in the tree are not 
selected, by default.

When an entity without a :: is selected all 
the objects below it are selected.

9. Double click on AAAA.1^::47. The submodel AAAA tree expands again 
and Rect[MAIN]::45 is displayed under-
neath AAAA.1^::47.

10. Select Rect[MAIN]::45. The output frame of the Model Browser 
shows that Rect[MAIN]::45 is a surface 
and is the only object selected.

MAIN is the name of the submodel for the 
surface’s conductors

Being a separate window, the Model Browser has its own title bar, menu bar, tool bar icons 
and Windows control buttons. If items are selected in the Model Browser tree, use the icons 
and menus in the Model Browser.

11.   or Edit > Edit on the Model 
Browser menu bar.
The Thin Shell Data dialog box appears.

Note: The Thin Shell Data dialog box for 
Rect::45 can also be displayed by double 
clicking on it.

Alternatively, you can right-click on 
Rect[MAIN]::45 and select Edit from the 
menu that appears

Model Browser Example  (Continued)
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12. Select the Surface tab.
13. Type Fred in the Comment field, as 

shown below. 
14. Select OK.

15.  to rebuild the data tree and dese-
lect the Rect-Fred::45.

Once the comment is added and OK 
selected, the tree “flashes” and rebuilds 
itself. The rectangle is renamed Rect-
Fred[MAIN]::45, incorporating the com-
ment that was entered.

This rebuilding capability is controlled 
with the Model Browser Options > Auto 
Update command. The Auto Update fea-
ture is useful with small models, but as 
models become larger, this can be time 
consuming.

Deselect Rect-Fred::45 and rebuild the 
tree.

Model Browser Example  (Continued)
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16. Select submodel AAAA.

17.  or Display > Only on the Model 
Browser menu bar. 

Notice the graphics in the main Thermal 
Desktop drawing area change to show 
only the selected items. Submodel AAAA 
is in the lower left of the drawing area. 

Note: It may be necessary to move the 
Model Browser out of the way, or 
minimize it, to view the drawing 
area.

18. Select Submodel Node Tree. The message Mixed Visibility for 
selected items appears in the lower 
portion of the Model Browser. This mes-
sage means that although there are many 
objects in the submodel node tree (and 
they are listed in the output frame) some 
of the selected items in the drawing area 
cannot be seen by the user (not visible).

19. Select Rect-Fred[MAIN]::45.

20.  or Display > Turn Visibility Off in 
the Model Browser.

This turns visibility off for the selected 
item.

21.  or Display > Undo Turn Visibility 
Off in the Model Browser

This reverses the last visibility change. If 
the last change was to turn the visibility 
of an object(s) on, then after this com-
mand the visibility will be turned off or 
vice versa.

22.
All the entities in the drawing are now 
visible. This command turns on the visi-
bility of all items on visible layers.

23. Select submodel BBBB. The lower portion of the Model Browser 
changes to display the objects associated 
with BBBB.

Model Browser Example  (Continued)
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24.   or Display > Turn Ids On on the 
Model Browser menu bar. 

The node IDs are displayed for submodel 
BBBB. 

25. Right-click on submodel BBBB and select 
Send Selection Set to AutoCAD.

Notice all items is submodel BBBB are 
highlighted.

26. Right-click on submodel CCCC and 
select Send Selection Set to AutoCAD.

The CCCC submodel is highlighted in the 
drawing area and grip points are dis-
played. 

Also, these entities are now an AutoCAD 
selection set, so any command issued 
outside of the Model Browser, such as 
Modify > Move, will function on these 
selected objects after making the main 
window active.

27. Hold down <Ctrl> and select submodel 
DDDD.

28. Right-click on submodel DDDD and 
select Send Selection Set to AutoCAD.

Both CCCC and DDDD are selected. 

Model Browser Example  (Continued)
20-7



29.   or Thermal > Case Set Manager 
on the main Thermal Desktop menu/
toolbar.
The Case Set Manager dialog box 
appears.

30. Select Case Set 0 if it is not already 
selected.

31. Select Run 1 Selected Case.
A Thermal Desktop/AutoCAD dialog box 
appears with a message stating Ther-
mophysical Property DEFAULT has not 
been defined. 

32. Select OK to close the dialog box.

The Case Set Manager is the link between 
Thermal Desktop and SINDA/FLUINT. 
Under the Case Set Manager, the user can 
define different solution sets for the 
model.

Case Set 0 is a simple steady-state analy-
sis.

After a Case Set is defined and selected, 
the Run 1 Selected Case button writes out 
the SINDA/FLUINT input files, starts 
SINDA/FLUINT and brings the results back 
into Thermal Desktop for postprocessing.

The Thermophysical Property DEFAULT is 
used only as a name place holder and 
does have property definitions. Therefore, 
the model definition is incomplete and 
the solution cannot be started.

33. Select List By > Thermo Props on the 
Model Browser menu bar.

This command rebuilds the Model 
Browser so that objects are listed by the 
materials that use them. 

Model Browser Example  (Continued)
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34. Click on the + next to DEFAULT -> to 
expand the list. 

35. Right-click on Rect[MAIN]::62 (the sur-
face) and select Edit.

The Thin Shell Data dialog box appears.

36. Click on the Cond/Cap tab.
37. Click on the arrow next to the Material 

field and select Stainless Steel from the 
drop-down list.

38. Select OK to close the dialog box.

Change the DEFAULT material to Stainless 
Steel.

Rebuilding the tree will verify that the 
DEFAULT material has been replaced.

39.  or Thermal >Case Set Manager on 
the main Thermal Desktop menu/tool-
bar.

Note: Rect::62 is still selected in the Model
Browser.

The Case Set Manager dialog box 
appears.

40. Select Run 1 Selected Case.
A Sinda/Fluint Run Status dialog box 
appears confirming the successful com-
pletion of the process.

41. Select OK to close the dialog box.

A solution is calculated for the default 
conditions: steady state with no radiation.
If the image below does not appear, select 
a different Layout tab at the bottom left of 
the Thermal Desktop window.

Model Browser Example  (Continued)
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42. Select List By > Submodel.Id from the 
Model Browser menu bar.

43. Select Submodel Node Tree, if not 
already selected.

44. Scroll down the list in the output portion 
of the Model Browser look at the addi-
tional available information.

The submodel tree rebuilds and the win-
dow is back to its original form.

In addition to the summary of the con-
tents of the model, the output portion of 
the Model Browser includes the tempera-
tures of the selected nodes, along with 
the Max and Min of the current selection 
set.

These values are the current postpro-
cessed data. If the current postprocessed 
data were heat rates, then these values 
would be heat rates.

To increase the size of the output portion 
of the window, the divider between the 
windows can be dragged.

45. Select Options > Temperatures from the 
Model Browser menu bar.

46. View the Output area.

Scrolling in the text window, you’ll see the 
output looks more like a SINDA TPRINT.

47. Select Options > Output Window on 
Bottom from the Model Browser menu 
bar to deselect it (remove the check 
mark).

This moves the output area to the right of 
the tree. The Model Browser window may 
be resized as desired. The example below 
shows the window resized horizontally 
and shortened.

Model Browser Example  (Continued)
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48. Select Submodel BBBB.
49. View the Output area.

Selecting on a single submodel, such as 
BBBB will show the data only for that sub-
model.

50. Select Options > CSG from the Model 
Browser menu bar.

51. Select Submodel Node Tree.
52. View the Output area.

Selecting Options > CSG shows the CSG 
of the selected nodes, sorted in lowest to 
highest order. The CSG is the capacitance 
of a node divided by the sum of all con-
ductances attached to it; it directly affects 
the timestep of the model for transient 
runs.

In order for the CSG to work, the SINDA 
save file must have capacitance and con-
ductors saved on it. This is set on the 
Output Tab of the Case Set Manager.

53. Select Options > Node Map from the 
Model Browser menu bar.

54. View the Output area.

Options > Node Map shows a SINDA-like 
NODMAP capability in order for the user 
to determine how energy is transferred 
into a node.

55. Select Options > Heat Map in the Model 
Browser.

56. Select submodel CCCC.
57. View the Output area.

The heat map shows the energy summary 
for energy into and out of the selected 
nodes. Energy between the selected 
nodes is not in the tabulation.

If submodel CCCC is selected, the heat 
map implies a load of 3W and has 3W 
leaving into submodel BBBB.

If submodels BBBB and CCCC are selected 
the heat map output will show the energy 
going from submodel BBBB into submodel 
AAAA, along with the 3W heat source on 
submodel CCCC.

Model Browser Example  (Continued)
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58. Select Options > Heat Flow Between 
Submodels in the Model Browser win-
dow.
The Heat Transfer Between Submodels 
dialog box appears. 

59. Click on the arrow next to the From 
Submodel field and select AAAA from 
the drop-down list.

60. Click on the arrow next to the To Sub-
model field and select BBBB from the 
drop-down list.

61. Select OK.

The results of the heat flow analysis is 3W 
going from submodel AAAA to submodel 
BBBB. The program cycles through all the 
nodes in submodel AAAA and sums the 
heat flows of all the conductors that con-
nect to submodel BBBB.

62.  or Thermal >Case Set Manager on 
the main Thermal Desktop menu/tool-
bar.
The Case Set Manager dialog box 
appears.

63. Select Case Set 1.
64. Select Run 1 Selected Case.

A Sinda/Fluint Run Status dialog box 
appears confirming the successful com-
pletion of the process.

65. Select OK to close the SINDA/FLUINT RUN 
STATUS dialog box.

Case Set 1 is a transient analysis that 
solves for 10,000 seconds.

Model Browser Example  (Continued)
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66. Select Submodel Node Tree.

67.  or Query > Plot Selected in the 
Model Browser menu. 

68. Minimize or close the EZXY PLOTTER win-
dow.

With transient results, only the data for 
the currently postprocessed results are 
shown in the Model Browser output 
frame.

The Plot command in the Model Browser 
creates a Data vs. Time plot of the post-
processed variable for all selected items 
in the model tree.

69. Close the Model Browser.
70. Select File > Exit.

A Thermal Desktop/AutoCAD dialog box 
appears asking to save the drawing 
changes.

71. Select Yes.

Exit Thermal Desktop and save as 
prompted.

Model Browser Example  (Continued)
20-13



20.4 Circuit Board Conduction Example

What will be learned:

■ Overview of how Thermal Desktop works
■ Creating material properties
■ Creating Thermal Desktop objects
■ Changing object colors
■ Applying an edge contactor
■ Applying a face contactor
■ Checking contactors
■ Outputting SINDA/FLUINT conductance and capacitance data for review

Prerequisites:

■ 20.2 Setting Up a Template Drawing

In this exercise, a circuit board will be mounted to an aluminum face. The circuit board will 
have a chip placed on it. 

Circuit Board Example

1. Copy the template thermal.dwg file created in the first tutorial to the \Tutori-
als\Thermal Desktop\board directory.

Note: Be sure to hold the <Ctrl> key down if dragging the template file icon to the new 
directory so that the file is copied, rather than moved.

2. Rename the copied template file to board.
3. Start Thermal Desktop by double clicking on the board drawing file icon in the board 

directory.

4.  or View > Visual Styles > 2D Wireframe to ensure consistency with the images 
in this tutorial.

5.  or Thermal > Thermophysical 
Properties > Edit Property Data.

This part of the exercise defines the ther-
mophysical properties for aluminum, fr4, 
and the chip.

The default units for Thermal Desktop are 
SI. These properties have the units of:

■ W/m/K for conductance
■ J/Kg/K for specific heat
■ kg/m^3 for density.
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6. Type Aluminum in the New property to 
add field.

7. Select the Add button.
The Edit Thermophysical Properties - 
Aluminum dialog box appears.

8. Highlight the current value in the Con-
ductivity field and type 237.

9. Highlight the current value in the Spe-
cific Heat field and type 900.

10. Highlight the current value in the Den-
sity field and type 2702.

11. Select OK.

Define properties for Aluminum.
Conductivity = 237 W/m/K

Specific heat = 900 J/kg/K

Density = 2702 kg/m^3

12. Type fr4 2 oz copper in the New prop-
erty to add field.

13. Select the Add button.
14. Highlight the current value in the Con-

ductivity field and type 17.7
15. Highlight the current value in the Spe-

cific Heat field and type 0.
16. Highlight the current value in the Den-

sity field and type 0.
17. Select OK.

Define properties for fr4 2 oz copper.
Conductivity = 17.7 W/m/K

Specific heat = 0 J/kg/K

Density = 0 kg/m^3

Zero values (0) for specific heat, density, 
or object thickness (covered later) will 
make the nodes arithmetic.

18. Type chip in the New property to add 
field.

19. Select the Add button.
20. Highlight the current value in the Con-

ductivity field and type 0.
21. Highlight the current value in the Spe-

cific Heat field and type 837.32
22. Highlight the current value in the Den-

sity field and type 2000.

Define properties for chip.
Conductivity = 0 W/m/K

Specific heat = 837.32 J/kg/K

Density = 2000 kg/m^3

The chip will be a single node. Therefore 
the chip’s internal conductivity is not 
used for these calculations, so any value 
can be used. If the chip were represented 
by multiple nodes, internal conduction 
could be ignored by either setting con-
ductivity of the material to 0 or setting 
the object thickness to 0 (covered later). 
However, setting the thickness to 0 will 
also create arithmetic nodes.

These values are approximations that are 
not really indicative of any particular chip.

Circuit Board Example (Continued)
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23. Select OK to close the Thermophysical 
Properties - chip dialog box.

24. Select OK to close the Edit Thermophys-
ical Properties dialog box.

Close the Thermophysical Properties dia-
log box.

25.  or Thermal > Preferences.
26. Select the Units tab if not already dis-

played.
27. Click on the arrow next to the Model 

Length field and select in (inches) from 
the drop-down list.

28. Select OK to close the User Preferences 
dialog box.

The model is to be built in inches. 

Notice that the energy units are in Joules, 
time in seconds, thus the energy rate 
units are Watts.

The properties set earlier are automati-
cally converted to inch (In) units.

Circuit Board Example (Continued)
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29.  or Thermal > Surfaces/Solids > 
Rectangle.
The Command line area should show:
Command: _RcRectangle

Origin point <0,0,0>:

30. Type 0,0

Note: Remember, <Enter> is implied after 
typing input.

The Command line should now read:
Point for +X axis and X-size 
<@1,0,0>:

31. Type 6,0
The Command line should now read:
Point to set XY plane and Y-size 
<@0,1,0>:

32. Type 0,3
The Thin Shell Data dialog box appears.

33. Click on the Subdivision tab if not 
already displayed.

34. Leave Centered Nodes selected.
35. Highlight the current value in the X-

direction Equal field and type 6
36. Highlight the current value in the Y-

direction Equal field and type 3

Input the appropriate data to make the 
aluminum plate with the proper nodaliza-
tion. A rectangle will be created for the 
aluminum plate.

■ Origin = 0,0
■ X length = 6
■ Y length = 3
■ Centered nodes
■ 6 subdivisions in the X direc-

tion
■ 3 subdivisions in the Y direc-

tion
When values are typed, they will automat-
ically be placed into the command line or 
next to the cursor; there is no need to 
physically click into the Command line 
area.

Inputs and/or prompts may appear next 
to the pointer when typed: this is referred 
to as Dynamic Input. This option can be 
changed with Tools > Drafting Settings 
on the Dynamic Input tab.

Circuit Board Example (Continued)
20-4



37. Click on the Cond/Cap tab.
38. Click on the arrow next to the Material 

field and select Aluminum from the 
drop-down list.

39. Highlight the current value in the Thick-
ness field and type 0.05

40. Select OK to close the Thin Shell Data 
dialog box.

41.  or View > Zoom > Extents.

Generate Nodes And Conductors must be 
selected to change the material and the 
thickness.

Set the material as Aluminum with a 
thickness of 0.05 in.

At the end of these steps, the screen 
should look similar to the view below: 

If OK is selected too soon, double-click 
the rectangle to re-enter the edit dialog.

Circuit Board Example (Continued)

Figure 20-7: Aluminum Plate
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42.  or Thermal > Surfaces/Solids > 
Rectangle.
The Command line area should show:
Command: _RcRectangle

Origin point <0,0,0>:

43. Type 0.25,1.5
The Command line should now read:
Point for +X axis and X-size 
<@1,0,0>:

44. Type @5.5,0
The Command line should now read:
Point to set XY plane and Y-size 
<@0,1,0>:

45. Type @0,0,3
The Thin Shell Data dialog box appears.

This part of the exercise creates the cir-
cuit board.
The @ sign input tells the program to 
input a point relative to the last point 
input. In this example, the @5.5,0 is the 
same as typing 5.75,1.5.

46. Click on the Cond/Cap tab if not already 
displayed. 

Additional information for the circuit 
board is to be added.

47. Highlight the current value in the Cond 
Submodel field and type board.

48. Click on the arrow next to the Material 
field and select fr4 2 oz copper from the 
drop-down list.

49. Highlight the current value in the Thick-
ness field and type 0.03 

When inputting board for the Cond sub-
model, the word board must be typed in. 
In the next step, on in the Numbering tab, 
board will have been added to the pull-
down list.

50. Click on the Subdivision tab.
51. Select Edge Nodes
52. Highlight the current value in the X-

direction Equal field and type 6
53. Highlight the current value in the Y-

direction Equal field and type 4 
54. Click on the Numbering tab.

Thermal Desktop does not calculate the 
conductance from nodes to the edges of 
surfaces connected by contact or contac-
tors. Therefore, that conductance should 
be included in the contact value or the 
better method, used here, is to use edge 
nodes.

Circuit Board Example (Continued)
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55. Click on the arrow next to the Submodel 
field and select BOARD from the drop-
down list.

56. Select OK to close the Thin Shell Data 
dialog box.

57.  or View > Zoom > Extents.

When finished, the model should look 
similar to the drawing below (the colors 
will be changed shortly).

58. Type LTSCALE.
The Command line should now read:
LTSCALE Enter new linetype scale 
factor <39.3701>:

59. Type 0.5

Change the Linetype scale factor so the 
edges of the new plate are more visible.

Circuit Board Example (Continued)

Figure 20-8: Board on Aluminum Plate
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60.  or Thermal > Preferences.
The User Preferences dialog box 
appears.

61. Select the Graphics Visibility tab. 
62. Clear TD/RC Nodes (remove the check 

mark from the box).
63. Select OK to close the User Preferences 

dialog box.
64. The nodes are no longer displayed.

The rectangle displayed in the drawing 
area is divided into six units long the X 
axis and three along the Y axis. There are 
small circles in the center of each unit. 
The small circles are the nodes. The node 
display is to be turned off.

Notice that the nodes do not line up with 
the aluminum plate.

This step in the exercise turns off the 
node display starting from the Thermal 
menu.

 Note that a much faster way to tog-
gle the display of nodes is to use the Tog-
gle TD/RC Node Visibility icon located at 
the lower the right side of the screen. 

Note: Some tool bar icons may not be 
visible within the Thermal Desktop 
window borders. As with basic 
Windows functionality, tool bars 
can be moved and docked as 
desired by the user. 

Circuit Board Example (Continued)
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65. Click on the newly created circuit board 
(the vertical rectangle) to select it.

66. Select the Color drop-down list (show-
ing ByLayer) and select Green

Change the color of the circuit board.

The default color of the circuit board is 
the color of the current layer (in this case 
the current color is white). The color is 
being overridden to change the circuit 
board to green.

Circuit Board Example (Continued)
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67.  or Thermal > Surfaces/Solids > 
Rectangle.
The Command line area should show:
Command: _RcRectangle

Origin point <0,0,0>:

68. Type 1.5,1.5,1.5
The Command line should now read:
Point for +X axis and X-size 
<@1,0,0>:

69. Type @1,0
The Command line should now read:
Point to set XY plane and Y-size 
<@0,1,0>:

70. Type @0,0,1
The Thin Shell Data dialog box appears.

71. Click on the Numbering tab.
72. Highlight the current value in the Sub-

model field and type chip.
73. Click on the Cond/Cap tab.
74. Click on the arrow next to the Cond 

Submodel field and select CHIP from the 
drop-down list.

75. Click on the arrow next to the Material 
field and select CHIP from the drop-
down list.

76. Highlight the current value in the Thick-
ness field and type 0.1

77. Select OK to close the dialog box.

Create a chip on the circuit board.

The chip is purposely being placed so that 
it overlaps the nodes on the board.

Instead of inputting the points, the points 
could be snapped to the drawing if 
desired.

Hint: <Shift> and click the right mouse 
button to access a menu for different 
types of snap points: select Node to snap 
to the center of a surface.

If CHIP is not in the drop-down list, then 
type it in.

Circuit Board Example (Continued)
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78. Click on the newly created chip to select 
it.

79. Select the Color drop-down list (show-
ing ByLayer) and select Red.

Change the color of the chip to red.

It may be necessary to ZOOM in to select 
the chip. When finished, the model should 
look similar to the drawing below. 

80. Select the newly created chip.

81.  or Modify > Move.
The Command line should now read:
Specify base point or [Displace-
ment] <Displacement>:

82. Type 0,-0.065,0 
The Command line should now read:
Specify second point or <use 
first point as displacement>:

83. Press <Enter>.
The chip is moved away from the circuit 
board.

It is good modeling practice to move the 
chip off of the board.

The distance of the offset shall be set to 
half of the sums of the thickness of the 
board (0.03) and the chip (0.1), which 
equals 0.065. The direction is in the neg-
ative Y direction because that is the direc-
tion in the current Coordinate System 
(UCS).

Remember that <ENTER> is assumed 
after typing into the command line. In 
actuality, <ENTER> is pressed twice.

Circuit Board Example (Continued)

Figure 20-9: Chip on Circuit Board
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84.  or Thermal > FD/FEM Network > 
Contactor.
The Command line should now read:
Select faces contacting from or 
[MB]:

85. Select the green circuit board in the 
drawing area.
The Command line should now read:
Select faces contacting from or 
[MB]:

86. Press <Enter>.
The Command line should now read:
Select surfaces contacting to or 
[MB]:

87. Select horizontal surface in the drawing 
area.
The Command line should now read:
Select surfaces contacting to or 
[MB]:

88. Press <Enter>.
The Contactor dialog box appears.

The board needs to conduct to the base 
plate. This can be accomplished by using 
a contactor.

Circuit Board Example (Continued)
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89. Click on the arrow next to the Conduc-
tor Submodel field and select BOARD 
from the drop-down list.

90. Click on the Contact From drop-down 
and select Edges.

91. Highlight the current value in the Con-
duction Coefficient field and type 5

92. Double-click Rect[BOARD]::274 in the 
From (1): list box.

93. In the Select Edges dialog, clear Along Y 
at X=0 and check Along X at Y=0

94. Select OK to close the Select edges dia-
log.

95. Select OK to close the Contactor dialog 
box.

The Contactor dialog box is displayed. 
Once the changes have been made and 
OK is selected, the graphical image for a 
contactor is displayed.

■ The from object will be shown 
as a green arrow showing the 
edge selected for contact.

■ The to object will be shown in 
gold and will have arrows 
pointing to both sides of the 
surfaces. 

The edge for the contactor is determined 
by the creation of the BOARD surface: the 
X at Y=0 edge is the first edge specified 
after the origin.

Circuit Board Example (Continued)

Figure 20-10: Edge Contactor
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96.  or Thermal > FD/FEM Network > 
Contactor.
The Command line should now read:
Select faces contacting from or 
[MB]:

97. Select the red chip in the drawing area.
The Command line should now read:
Select faces contacting from or 
[MB]:

98. Press <Enter>.
The Command line should now read:
Select surfaces contacting to or 
[MB]:

99. Select green circuit board in the drawing 
area.
The Command line should now read:
Select surfaces contacting to or 
[MB]:

100. Press <Enter>.
The Contactor dialog box appears.

The chip needs to conduct to the board. 
This can be accomplished by using a con-
tactor.

Circuit Board Example (Continued)
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101. Click on the arrow next to the Conduc-
tor Submodel field and select CHIP from 
the drop-down list.

102. Highlight the current value in the Con-
duction Coefficient field and type 5

103. Select Show Calcs at the bottom right to 
close the Contactor dialog box and show 
the contactor markers.

The Contactor dialog box is displayed. 
Once the changes have been made and 
OK is selected, the graphical image for a 
contactor is displayed.

■ The from surface will be 
shown as a green arrow show-
ing the side selected for con-
tact.

■ The to surfaces will be shown 
in gold and will have arrows 
pointing to both sides of the 
surfaces. 

Notice the green arrow points away from 
the circuit board. Since the default con-
tactor has infinite tolerance and uses a 
point distance method, this will work fine 
for this case, but technically the contactor 
should be edited, and then the user 
should double click on the from surface 
to change the side of contact. If the sur-
face had different nodes on each side, or 
if the ray trace algorithm was being used 
for the contactor, then this change would 
be mandatory in order to get the correct 
results.

Circuit Board Example (Continued)

Figure 20-11: Face Contactor
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Yellow lines representing the contacts 
are displayed.

If the contactors dialog is closed without 
using Show Calcs, the contactor moarkers 
can be displayed using Thermal > Model 
Checks > Show Contactor Markers com-
mand, which shows the actual calcula-
tions for the contact.

Note: When items are connected, yel-
low lines are drawn from the con-
tact point(s) to the node with 
which it is connected. The number 

of test points is controlled in the 
Contactor dialog box, displayed 
earlier when the contactor was 
being created, as the Integration 
Intervals. A value of 10 integration 
intervals means the 10*10, or 
100, points will be tested. In this 
model, notice that the chip is con-
nected to 2 nodes.

If an object does not connect to a 
node, then it is displayed as a red 
point. To prevent an object from 
hooking up, the tolerance on the 
Contactor dialog box must be 
changed from the default of infin-
ity to a smaller value. 

Circuit Board Example (Continued)

Figure 20-12: Contactor Markers
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104.  or Thermal > Model Checks > 
Clear Contact/or Markers 

105. Select Thermal > Model Checks > Show 
Contactor Markers and display markers 
for the other contactor.

106. Double-click the text Double-click to 
Reset Graphics

This command deletes the contactor 
marker lines. It actually deletes all the 
items on the “Radcad_rays” layer.

107. Select Thermal > Cond/Cap Calculations 
> Output SINDA/FLUINT Cond/Cap.

This part of the exercise demonstrates 
the Output SINDA/FLUINT Cond/Cap 
command. This command outputs the 
conductors and capacitance for the model 
to the file SINDA.CC located in the same 
directory as the drawing, in this case in 
the board directory.

If the SINDA.CC file is opened in a text 
editor three different node blocks—MAIN 
(aluminum base), (circuit) BOARD, and 
CHIP—are detailed.

In the conductor data for the chip, the 
chip is tied to two nodes on the circuit 
board representing the planar contact 
area. Likewise, the circuit board is tied to 
several nodes on the base representing 
the linear contact conductance.

108. Select File > Exit.
A Thermal Desktop/AutoCAD dialog box 
appears asking if the user wants to save 
changes to the board.dwg.

109. Select Yes.
The drawing is saved and Thermal 
Desktop is closed.

Note: It is good practice whenever 
working on a computer to periodi-
cally perform File > Save com-
mands during the course of a 
session to help ensure work is not 
lost.

Circuit Board Example (Continued)
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20.5 Beer Can Example

What will be learned:

■ Overview of how Thermal Desktop works
■ Creating material properties
■ Creating Thermal Desktop objects
■ Changing global visibility options
■ Extruding planar objects into solid elements
■ Surface coating free solid finite element faces
■ Using model checks to verify model development
■ Using of arbitrary nodes and conductors
■ Using AutoCAD layers to control object visibility
■ Using the Case Set Manager
■ Parameterizing a model
■ Creating XY time-dependent plots

Prerequisites:

■ 20.2 Setting Up a Template Drawing

In this example, a beer can full of beer will be constructed. The initial temperatures will be set 
to something similar to a refrigerator temperature of 5C. Free convection heat transfer coeffi-
cients will be applied to the sides of the can and the top of the can. 

Beer Can Example

1. Copy the template thermal.dwg file created in the first tutorial to the \Tutori-
als\Thermal Desktop\beercan directory.

Note: Be sure to hold the <Ctrl> key down if dragging the template file icon to the new 
directory so that the file is copied, rather than moved.

2. Rename the copied template file to beercan.
3. Start Thermal Desktop by double clicking on the beercan drawing file icon in the 

beercan directory.
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4.  or select Thermal > Thermophys-
ical Properties > Edit Property Data.
The Edit Thermophysical Properties dia-
log box appears. 

5. Type Aluminum in the New property to 
add field.

Note: See comments in the right-hand col-
umn.

6. Select the Add button.
The Thermophysical Properties dialog 
box appears.

This part of the exercise defines the ther-
mophysical properties for aluminum and 
water.

If the tutorials are being performed in 
order from the beginning of the tutorial 
chapter, the user will have already defined 
Aluminum properties in the board model. 
Instead of redefining the properties, the 
user has two choices:

■ First, it is possible to use the 
Thermal > Thermophysical 
Properties > Open/Create 
Property DB... command to 
open the database created in 
the board example. The Alu-
minum defined there could be 
used and the Water definitions 
added to that database. In the 
case, the material property will 
be stored in the Board tutorial 
folder.

■ Second, the user can import 
the Aluminum properties from 
the Board tutorial database 
into the Beer tutorial database. 
Once the Edit Thermophysical 
Properties dialog is open, 
select the Import button. Open 
the database created in the 
board example and select Alu-
minum from the list of avail-
able properties. In the case, 
the material properties will be 
stored in the Beercan tutorial 
folder.

Note: If a Material is already listed in 
the Edit Property Data dialog box 
but one or more of the properties 
is different than what is needed, 
double click on the material of 
interest. The Thermophysical 
Properties dialog box will appear 
allowing changes to be made.

Beer Can Example (Continued)
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7. Highlight the current value in the Con-
ductivity k field and type 237.

8. Highlight the current value in the Spe-
cific Heat cp field and type 900.

9. Highlight the current value in the Den-
sity rho field and type 2702.

10. Select OK to close the Thermophysical 
Properties dialog box.
The Edit Thermophysical Properties dia-
log box reappears with Aluminum and 
the above values displayed in the main 
property/description field.

11. Type Water in the New property to add 
field.

12. Select the Add button.
The Thermophysical Properties dialog 
box appears.

13. Highlight the current value in the Con-
ductivity k field and type 0.6.

14. Highlight the current value in the Spe-
cific Heat cp field and type 4200.

15. Highlight the current value in the Den-
sity rho field and type 1000.

16. Select OK to close the Thermophysical 
Properties dialog box.
The Edit Thermophysical Properties dia-
log box reappears with water and the 
above values displayed in the main 
property/description field.

17. Select OK to close the Edit Thermophys-
ical Properties dialog box.

As in real projects, some assumptions 
must be made.

Beer Can Example (Continued)
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18.  or Thermal > Preferences.
The User Preferences dialog box 
appears.

19. Select the Units tab if not already dis-
played.

20. Click on the arrow next to the Model 
Length field and select in (inches) from 
the drop-down list.

21. Select the Graphics Visibility tab. 
22. Clear TD/RC Nodes (remove the check 

mark from the box).
23. Select OK to close the User Preferences 

dialog box.

These steps change the units for the 
model to inches and turns off TD/RC 
node visibility for all the nodes that are 
attached to the surface.

Beer Can Example (Continued)
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24.  or Thermal > Surfaces/Solids > 
Disk.
The Command line should now read:
Pick or enter point for center of 
disk <0,0,0>:

25. Type 0,0 in the Command line.
The Command line should now read:
Pick or enter point for +Z axis 
of disk <@0,0,1>:

26. Type 0,0,1 in the Command line.
The Command line should now read:
Enter maximum radius or pick/
enter point <1.0>:

27. Type 1.3125 in the Command line.
The Command line should now read:
Enter minimum radius or pick/
enter point <0.0>:

28. Press <Enter>.
The Command line should now read:
Enter start angle or pick/enter 
point <0.0>:

29. Press <Enter>.
The Command line should now read:
Enter end angle or pick/enter 
point <360.0>:

30. Press <Enter>.
The Thin Shell Data dialog box appears 
displaying default values.

31. Click on the Subdivision tab if not 
already displayed.

32. Click on the radio button next to Edge 
Nodes to select it (display a dot in the 
circle).

Create the bottom of the aluminum can.

Specify the origin.

Define the axis direction.

Using edge nodes is important since finite 
elements will be extruded from this disk. 
If centered nodes are used, then the finite 
elements will not fill the entire volume of 
the can.

Beer Can Example (Continued)
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33. Highlight the current value in the Angu-
lar Equal field (subdivisions) and type 9.

34. Highlight the current value in the Radial 
Equal field (divisions) and type 3. 

35. Click on the Cond/Cap tab. 
36. Click on the arrow next to the Material 

field and select Aluminum from the 
drop-down list.

37. Highlight the current value in the Thick-
ness field and type .05.

38. Select OK to close the Thin Shell Data 
dialog box.

39.  or View > Zoom > Extents.

When completed, this disk will represent 
the bottom of the beer can. This part of 
the exercise sets the disk properties.

Note: If the OK button is accidentally 
selected before switching to the 
Cond/Cap tab, simply select the 
disk and select Thermal > Edit to 
get back to the form.

40. Select the newly created disk.
41. Select Thermal > FD/Fem Network > 

Extrude Normal To Planar Elements into 
Solids.
The Extrude/Revolve Planar Elements 
into Solids dialog box appears. (Next 
page)

The disk will be extruded into solid ele-
ments. 

Beer Can Example (Continued)
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42. Leave Even Breakdowns selected (dot in 
the circle).

43. Highlight the current value in the Total 
Distance field and type 4.75.

44. Highlight the current value in the Solids 
created along path field and type 4.

45. Highlight the current value in the ID 
Increment for new nodes field and type 
100. 

46. Select OK to close the dialog box.

Note: After the extrusion is com-
pleted, if the geometry looks like 
there is a hole in the middle of the 
extruded solids then Edge Nodes 
(Subdivision tab in the Thin Shell 
Data dialog box) was not selected 
when the disk was created. Per-
form the following steps to make 
the correction:

■ Press <Ctrl>< Z> to undo the 
extrusion.

■ Edit the disk to make the 
nodes edge nodes as follows:

■ Select the disk in the drawing 
area.

■ Select Thermal > Edit.
■ In the Thin Shell Data dialog 

box, select the Subdivision tab 
and make the corrections. 
Click on OK.

■ Return to Step 40.

Beer Can Example (Continued)
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47.  or Thermal > Edit.
The Command line should now read:
Select Objects or [Indiv MB]:

48. Type all in the Command line.
The model in the drawing area is 
selected and Select Objects or 
[Indiv MB]: appears in the Command 
line area.

49. Press <Enter>.
The Object Selection Filter dialog box 
appears. 

50. Click on Solid Elements(64) to select it.

The newly created solids must be edited 
to change their material to water. The 
properties of water are being used as an 
assumption of the properties of beer.

Only one type of object can be edited at a 
time. The Object Selection Filter makes it 
easy to select the desired object from the 
list.

Beer Can Example (Continued)
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51. Select OK to close the selection filter and 
select the solid elements.
The Solid Elements Attributes dialog box 
appears. 

52. Click on the arrow next to the Material 
field and select Water from the drop-
down list.

53. Select OK to close the dialog box.
A Thermal Desktop/AutoCAD dialog box 
appears confirming the change.

54. Read the content of the dialog box and 
select Apply Changes.

Beer Can Example (Continued)
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55. Select Thermal > FD/Fem Network > 
Surface Coat Free Solid FEM Faces.
The Command line should now read:
Select the solids for free face 
calculations or [MB]:

56. Type all in the Command line.
The Command line should now read:
64 found

Select the solids for free face 
calculations or [MB]:

57. Press <Enter>.
The Thin Shell Data - Multiple Surface/
Element Edit Mode dialog box appears. 

58. Click on the Cond/Cap tab.
59. Click on the arrow next to the Material 

field and select Aluminum from the 
drop-down list.

60. Highlight the current value in the Thick-
ness field and type 0.03

Place the aluminum shell around the rest 
of the can. The solids will be surface 
coated to place the shell around the outer 
cylinder and the top.

Surface coating will place a planar ele-
ment using the same nodes used by the 
solid elements. The command is smart 
enough to figure out that the outside 
faces are not hooked up to other solids 
(and creates the planar element there), 
while the inside faces are hooked to more 
than one solid, so those faces are not 
free.

Beer Can Example (Continued)
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61. Select OK to close the dialog box.
A Thermal Desktop/AutoCAD dialog box 
appears confirming the change.

62. Read the content of the dialog box and 
select Apply Changes.

63.  or View > Zoom > Extents.

Beer Can Example (Continued)
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64.  or Thermal > Edit.
Select Objects or [Indiv MB]: 
appears in the Command line area

65. Type all in the Command line.
198 found

Select Objects or [Indiv MB]: 
appears in the Command line area.

66. Press <Enter> to end the selection pro-
cess.
The Object Selection Filter dialog box 
appears.

67. Click on Nodes(85) in the Select Type to 
Filter field to select it.

68. Select OK to close the dialog box.
The Node - Multi Edit Mode dialog box 
appears.

69. Highlight the current value in the Initial 
temp field and type 278.15.

70. Select OK to close the dialog box.
A Thermal Desktop/AutoCAD dialog box 
appears confirming the change.

71. Read the content of the dialog box and 
select Apply Changes.

This part of the exercise edits all of the 
nodes to set their initial temperatures.

Beer Can Example (Continued)
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72.  or Thermal > FD/Fem Network > 
Node.
The Command line should now read:
Enter location of node:

73. Type 3,0,0 in the Command line.
The node appears to the right of the 
model.

Create a node to connect to a convective 
conductor. This node will represent the 
ambient air temperature. 

74. Select the newly created node.

75.  or Thermal > Edit.
The Node dialog box appears.

76. Highlight the current value in the Sub-
model field and type Air.

77. Click on the radio button next to 
boundary in the Type field to select it 
(display a dot in the circle).

78. Double click in the Initial temp field.
The Expression Editor dialog box 
appears. 

The node will be edited to make it a 
boundary node and placed in submodel 
air.

Notice that sometimes objects are 
selected before the command and some-
times after the command. If objects are 
selected before the command, then the 
first operation of the command uses the 
“pre-selected” objects if they are the right 
type. If a command requires objects, but 
nothing is selected before the command, 
then the command line will query for the 
needed objects.

The temperature of the node will be 
defined as a symbol, making it easy to set 
up a second case that has different air 
temperature.

Note: The Expression Editor is dis-
played when the mouse is double 
clicked in a field.

Beer Can Example (Continued)
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79. Select the Add Symbol button.
The Symbol Manager dialog box 
appears. 

80. Type Airtemp in the New Symbol Name 
field.

81. Select Add.
An Expression Editor dialog box for Air-
temp appears.

Before using the symbol in the definition 
of the initial temperature, the symbol 
must be created.

Beer Can Example (Continued)
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82. Type 20 in the main entry field. 
83. Type deg C in the Description field

84. Select OK to close the Airtemp Expres-
sion Editor dialog box.
The Symbol Manager dialog box is 
updated with the Airtemp information 
displayed.

Note: Symbols do not have units 
associated with them. When they 
are applied units are then 
assigned.

Beer Can Example (Continued)
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85. Select Done in the Symbol Manager dia-
log.
The Expression Editor dialog box reap-
pears.

86. Click on the arrow underneath Select 
units for: Temperature and select C 
from the drop-down list.

87. Right-click the Expression field, select 
General and then select Airtemp. 

88. Select OK to close the Expression Editor 
dialog box.

Note: The Initial Temp value is now in bold 
type and should read 293.15.

Now that the symbol for the air tempera-
ture has been defined, the expression for 
the temperature of the boundary node 
can be created.

Note: Symbols do not have units 
associated with them. When they 
are applied units are then 
assigned.

Beer Can Example (Continued)
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89. Select OK to close the Node dialog box.
The node’s shape is changed to reflect 
its designation as a boundary node.

90. Select View > 3D Views > Front.
The view changes. Note the UCS icon 
also moves to the lower left of the draw-
ing area.

91. Type Zoom in the Command line.
The Command line should now read:
All/Center/Dynamic/Extents/Pre-
vious/Scale/Window/Object <real 
time>:

92. Type 0.9x in the Command line.

Note: When this portion of the ex-
ercise is completed, the shape of the
node changes to designate that it is
now a boundary node. 

Change the view from the current SW Iso-
metric to a Front view.
The view should look as follows. Note the 
new node in the lower right-hand corner.

Beer Can Example (Continued)
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93.  or type layer in the Command 
line.

Note: The menu selection Format > Layer 
may also be used.

The Layer Properties Manager dialog 
box appears. 

94.  to create a new layer.
A new layer named Layer1 is added.

95. Highlight the name Layer1 (if not 
already highlighted) and type Conduc-
tors to change the name of this newly 
created layer.

96. Select the Freeze icon (sun) for the Con-
ductors layer to freeze it (change the 
sun to a snowflake).

97. Close the Layer Properties Manager dia-
log box.

A new layer is to be created for the con-
ductors to reside on.

Beer Can Example (Continued)
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98.  or Thermal > FD/Fem Network > 
Node to Surface Conductor.
The Command line should now read:
Select node or [MB]:

99. Click on the boundary node (lower right 
on the screen).
The Command line should now read:
Select surfaces or [MB]:

100. Select surfaces: Select from 1 to 2 as 
shown in to the right and as noted 
below:
■ Using the example to the right as 

a guide, click the left mouse out-
side and above the upper left cor-
ner of the surface area (1).

The Command line should now read:
Specify opposite corner:

■ Position the mouse outside and 
below the opposite, lower right 
corner of the surface area as 
shown in the example and click 
the left mouse button (2). Note 
that as the mouse is moved, a box 
is drawn around the area.

The Command line should now read:
Select surfaces:

101. Press <Enter>.
102. Select the new conductor.

Note: The new conductor set can be selected 
by picking any line of the set.

The next steps create the conductors and 
connect them to the surface.

When prompted to select the surface 
areas on the beer can, it is important to 
drag-select from the top left to bottom 
right since selecting in the reverse direc-
tion has a different meaning in AutoCAD 
(see example below).

A set of eight lines (representing the con-
ductor) from the boundary node to the 
surface area are displayed.

Beer Can Example (Continued)
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103. Thermal > Edit.
The Conductor dialog box appears.

104. Type Top Convection in the Comment 
field.

105. Click on the Type arrow and select Nat-
ural Convection Horizontal Flat Plate 
Upside from the drop-down list.

106. Select Change Fluid.
107. Expand Library and select Air (Perfect 

Gas)
108. Select OK to close the fluid selection.
109. Highlight the current value in the Area/

Perimeter field and type 0.65625
110. Select OK to close the dialog box.

Edit the new conductor.
For the disk:

■ radius = 1.3125.
■ area = pi*r^2
■ perimeter = pi*r*2
■ Area/Perimeter = radius/2

Change the fluid to be air

111. Select the new conductor.
112. Click on the Layer Control drop-down in 

the upper right toolbars, as shown, and 
select Conductors.

113. Select Close to confirm the change and 
close the dialog box.
The conductor moves to the Conductor 
layer, which is frozen, and disappears 
from the screen.

This part of the exercise moves the con-
ductor to the Conductor layer that was 
frozen in the previous step. Doing this 
will make the display less cluttered.

Beer Can Example (Continued)
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114. Thermal > FD/Fem Network > Node To 
Surface Conductor.
The Command line should now read:
Select node or [MB]:

115. Select the boundary node (lower right).
The Command line should now read:
Select surfaces or [MB]:

116. Draw a selection box from points 1 to 2 
as shown in figure to the right and as 
noted below:
■ Using the example to the right as 

a guide, click the left mouse at the 
lower right area of the surface 
area (1).

The Command line should now read:
Specify opposite corner:

■ Position the mouse on the oppo-
site, upper left of the surface area 
as shown in to the right and click 
the left mouse button (2). Note 
that as the mouse is moved, a box 
is drawn around the area.

The Command line should now read:
Select surfaces or [MB]:

117. Press <Enter>.
A set of sixteen lines (representing the 
conductor) from the boundary node to 
the surface area are displayed.

The drawing below shows the correct 
point selection order to be used for the 
next steps. It is important to begin in the 
lower right area of the beer can (first 
point, 1), as shown, and move the mouse 
to the upper left area (second point, 2).
When selecting from the bottom right to 
the top left, any entity that is fully or par-
tially enclosed will be included in the 
selection set. If the selection order is 
changed (point 2 and then point 1) only 
the items that are fully included in the 
box will be included in the selection set.

When these steps are completed, the 
screen should appear similar to the 
example below.
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118. Select the new conductor.
119. Thermal > Edit.

The Conductor dialog box appears.
120. Type Side Convection in the Comment 

field.
121. Click on the Type arrow and select Nat-

ural Convection Vertical Cylinder - Iso-
thermal from the drop-down list.
The content of the Conductor dialog box 
changes to reflect the selection.

122. Select Change Fluid.
123. Expand Library and select Air (Perfect 

Gas)
124. Select OK to close the fluid selection.
125. Highlight the current value in the Height 

field and type 4.75.
126. Highlight the current value in the Diam-

eter field and type 2.625.
127. Select OK to close the Conductor dialog 

box.

128.  or select Thermal > Model 
Browser.
The Model Browser appears. 

129. Select List By > Conductors in the Model 
Browser.
The Model Browser tree displays the 
Conductor Tree

130. Right-click on Cond-Side Convection 
under MAIN and select Change Layer > 
Conductors.
The conductor moves to the Conductor 
layer, which is turned off, and disap-
pears from the screen.

131. Close or minimize the Model Browser 
window.

As with the first conductor, this new con-
ductor will be moved from layer 0 to the 
layer Conductor so that it does not clutter 
up the display.
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132. Select Thermal > Model Checks > List 
Duplicate Nodes.
The Command area should now show:
Listing of duplicate nodes

No duplicate nodes were found

Note: If the statement does not appear in the 
command line, press <F2> to view the 
complete Command line comments.

Before any geometry building is complete, 
it is important to look for duplicate 
nodes. If any duplicate nodes are found, it 
may be necessary to use the Resequence 
IDs command to renumber them.

Note: See 7.3 Resequence IDs.

Look at the output and see if any are 
found.

Beer Can Example (Continued)
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133.  or Thermal > Preferences.
The User Preferences dialog box 
appears.

134. Select the Graphics Visibility tab if not 
already displayed.

135. Click on User Defined Nodes to clear it 
(remove the check mark from the box). 

136. Select OK to close the dialog box.
The air node disappears from the draw-
ing area.

Turn off the display of the air node.
Alternatively, the visibility of some 
objects can be toggle off and on using 
icons in the toolbars. For User Defined 
Nodes, it is the icon:

Beer Can Example (Continued)
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137.  or type layer in the Command 
line.
The Layer Properties Manager dialog 
box appears.

138.  to create a new layer.
A new layer named Layer1 is added to 
the existing layers.

139. Highlight the name Layer1 if not already 
highlighted. Type RightSide to change 
the name of this newly created layer.

140. Select the Freeze icon (sun) for the 
RightSide layer to turn freeze it (change 
the sun to a snowflake), if it is not 
already frozen. 

141. Close the Layer Properties Manager dia-
log box.

Create a new layer called RightSide, which 
is where the right side of the beer can will 
be placed.

New layers use the settings of the 
selected layer when they are created. If 
the Conductor is selected when the new 
layer is created, then the new layer will be 
frozen.
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142. Select the right side of the beer can by 
drawing a selection box from points 1 to 
2 as shown on the right and as noted 
below:
■ Using the example to the right as 

a guide, click the left mouse at the 
lower right area of the surface 
area (1).

Specify opposite corner: appears in 
the Command line area.
■ Position the mouse as shown in to 

the right (above and to the right of 
the middle line) and click the left 
mouse button (2). Note that as the 
mouse is moved, a box is drawn 
around the area.

The right side of the can is selected in 
the drawing area.

143. Click on the Layer Control drop-down in 
the upper right toolbars, as shown, and 
select RightSide.

144. Select Close to confirm the change and 
close the dialog box.

Split the beer can into two sides so that 
the temperatures in the middle of the 
beercan can be determined later in the 
exercise. \

Once the selected right side is moved to 
the RightSide layer, the drawing area 
should look similar to the example below:

Beer Can Example (Continued)
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145. Select View > 3D Views > SE Isometric.
The new view appears in the drawing 
area.

The new view should now look as follows. 

Beer Can Example (Continued)
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146.  or Thermal > Model Checks > 
Color by Property Value > Conductivity.

Note: If the blue is a little dark, feel free to 
rotate a little bit to see if better. This is 
also a good time to review graphics set-
tings (19.4 Graphics Settings).

147. Select View > 3D Views > SE Isometric.

This command verifies that the materials 
are set correctly. The picture should look 
similar to the view below (you may need 
to rotate the model) with the aluminum 
being about 6 and the water being about 
0.01. If the values are not right, edit the 
material property of the incorrect entities.
Some elements may appear wrong, but 
this is likely a graphics issue.

148.  or Thermal > Model Checks > 
Color by Property Value Off.
The model reverts back to the previous 
wireframe view.

Beer Can Example (Continued)
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149.  or Thermal > Case Set Manager.
The Case Set Manager dialog box 
appears.

150. Select Edit.
The Case Set Information dialog box 
appears. (next page)

The Case Set Manager changes the view 
from the geometric model to tempera-
tures with the click of a button.
The default process is to run a steady 
state case, but a transient run is what is 
needed here.
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20-29



151. Select the Calculations tab. 
152. Click on Steady State in the Solution 

Type field to clear it (remove check mark 
from the box).

153. Select Transient in the Solution Type 
field to select it (place a check mark in 
the box).

154. Highlight the current value in the End 
Time field and type 3600.

On the Calculations tab, the Solution type 
is chosen and, since a transient analysis is 
desired, an end time is set.

Beer Can Example (Continued)
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155. Select the Output tab. 
156. Highlight the current value in the Ther-

mal Output Increment field and type 
100.

157. Select OK.

The Case Set Manager dialog box is on 
the screen.

The Output Increment defines how often 
during the solution the chosen values will 
be written to the output files.
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158. Select Run 1 Selected Case.

A SINDA/Fluint Run Status dialog box 
appears stating the successful comple-
tion of the processor.

159. Select OK to close the dialog box.
The model changes from the geometric 
view.

When the run is complete the temperature 
view should look similar to the following. 

If the solution fails, please check the air 
node temperature. If it is accidentally 
input as 20K, the solution will fail.
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160.  or Thermal > Post Processing > 
Edit Current Dataset.
The Set SINDA Dataset Properties dialog 
box appears. 

161. Scroll down the list in the Select a Time/
Record [sec] field and select 3600 
(3.60e+003).

162. Select OK.

After the solve is completed, the initial 
temperatures are displayed on the model 
in the postprocessing state.

Note: If the colors do not look right,
please 19.4 Graphics Settings. 

163.  or Thermal > Post Processing > 
Post Processing Off.
The model returns to the geometric view 
in the drawing area.
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164.  or Thermal > Case Set Manager.
The Case Set Manager dialog box 
appears.

165. Select Copy.

The Copy Case Set dialog box appears. 

166. Highlight the current value in the in the 
New Case Set Name field and type Hot 
Case.

167. Select OK to close the dialog box.
The Case Set Manager dialog box 
updates to reflect Hot Case in the Case 
Sets field.

168. Select Hot Case.

169. Select Edit.
The Editing 1 Case Set - Hot Case dialog 
box appears.

Create a hot case where the air tempera-
ture is 25 °C.
By overriding the global definition of 20 
°C with 25 °C, the new case can be run 
quickly and it will be able to go back to it 
at a later time.
When this case is run, all the SINDA files 
will go to case1.*
Once the run is finished, edit the post-
processing dataset to change to the end 
time. 
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170. Select the Symbols tab. 
171. Select Airtemp in the Global List field to 

highlight it.
172. Click on the right arrow located in the 

center of the dialog box. 

The Expression Editor (Airtemp) dialog 
box appears.

173. Highlight the current value in the main 
entry field (20) and type 25

174. Select OK to close the dialog box.
The Case Set Information - Hot Case 
dialog box displays the change.
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175. Select OK to close the Case Set Informa-
tion - Hot Case dialog box and re-dis-
play the Case Set Manager dialog box.

176. Select Run 1 Selected Case.

A SINDA/Fluint Run Status dialog box 
appears stating the successful comple-
tion of the processor.

177. Select OK to close the dialog box.
The model changes from the geometric 
view.

178.  or Thermal > Post Processing > 
Edit Current Dataset.
The Set SINDA Dataset Properties dialog 
box appears. 

179. Scroll down the list in the Select a Time/
Record [set] field and select 3600 
(3.60e+003).

180. Select OK.

181.  or Thermal > Utilities > Capture 
Graphics Area.

The Thermal > Utilities > Capture Graph-
ics Area will save the current graphics 
window to ScreenCapture1.bmp. The pro-
gram determines the lowest ScreenCap-
ture# that it can use so as to not overwrite 
an existing file. For example, a second 
command would save to ScreenCap-
ture2.bmp.
To verify the graphic is saved, open the 
beercan directory folder and ScreenCap-
ture1 will be included.
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182.  or Thermal > Post Processing> 
Animate Through Time.
The Continuous Cycle Dialog dialog box 
appears. 

183. Select OK.

184. View the screen.

This command will animate through all 
the times on the postprocessing file.

185.  or Thermal > Post Processing > 
Post Processing Off.
The model returns to the geometric view 
in the drawing area.

Beer Can Example (Continued)
20-37



186. Select an element in the drawing

187.  or select Thermal > Post Process-
ing > X-Y Plot Data vs. Time.

188. View the results.

This command will bring up the external 
XY Plotting program. This program will 
plot the transient for nodes of the ele-
ment that have been selected. 

Note: The results will be different
depending upon what was selected
in the drawing area.

The user can change the nodes displayed 
by selecting the Edit > Add/Edit menu 
command in EZXY.
The nodes being displayed and any plot 
customization can be saved to a file that 
can then be brought up external to Ther-
mal Desktop.

189. Select File > Exit.
A Thermal Desktop/AutoCAD dialog box 
appears asking to save the drawing 
changes.

190. Select Yes.

Exit Thermal Desktop and save as 
prompted.
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20.6 Conduction and Radiation Using Finite Elements

What will be learned:

■ Creating planar finite elements
■ Extruding and revolving planar elements into solid finite elements
■ Verifying proper connections of elements
■ Surface coating finite element solids for radiation, area contact, or insulation

Prerequisites:

■ 20.2 Setting Up a Template Drawing

In this example, a finite element model will be created with fixed temperatures at either end. 
The process begins by creating a single quad element. The AutoCAD array command will be 
used to create a grid of elements. The planar quad elements will be extruded and revolved 
into 3D solid elements. The solid elements will be surface-coated with zero-thickness planar 
elements to be used in a later tutorial for assigning radiation properties. Temperature 
boundary conditions will be applied and the model will be solved by SINDA. Radiation will be 
optionally added to the analysis at the end of the tutorial.

Finite Element Example

1. Copy the template thermal.dwg file created in the first tutorial to the \Tutori-
als\Thermal Desktop\finiteElement directory.

Note: Be sure to hold the <Ctrl> key down if dragging the template file icon to the new 
directory so that the file is copied, rather than moved.

2. Rename the copied template file to fe1.dwg.
3. Start Thermal Desktop by double clicking on the fe1 drawing file icon in the finiteEle-

ment directory.
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4.  or select Thermal > Thermophysi-
cal Properties > Edit Property Data.
The Edit Thermophysical Properties dia-
log box appears.

5. Type Aluminum in the New property to 
add field.

6. Select the Add button.
The Thermophysical Properties dialog 
box appears. 

7. Highlight the current value in the Con-
ductivity k field and type 240.

8. Select OK to close the Thermophysical 
Properties dialog box.
The Edit Thermophysical Properties dia-
log box reappears with the updated Alu-
minum value displayed in the main 
property/description field.

9. Select OK to close the Edit Thermophys-
ical Properties dialog box.

Create the property aluminum with a con-
ductivity of 240. Only the conductivity will 
be entered/updated. This will be a steady 
state example.

Depending upon where the user started 
the tutorials, Aluminum may already 
exist. If so, perform Step 4, double click 
on Aluminum in the Edit Thermophysical 
Properties dialog box and move to Step 7.

Finite Element Example (Continued)
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10.  or Thermal > FD/FEM Network > 
Node.
The Command line should now read:
Enter location of node:

11. Type 0,0 in the Command line.
The first node is created at the origin.

12.  or Thermal > FD/FEM Network > 
Node.
The Command line should now read:
Enter location of node:

13. Type 1,0 in the Command line.
The second node is created.

14.  or Thermal > FD/FEM Network > 
Node.
The Command line should now read:
Enter location of node:

15. Type 1,1 in the Command line.
The third node is created.

16.  or Thermal > FD/FEM Network > 
Node.
The Command line should now read:
Enter location of node:

17. Type 0,1 in the Command line.
The fourth node is created.

18.  or View > Zoom > Extents.

This part of the exercise creates 4 nodes. 
When finished, the model should look 
similar to the example below.

To repeat a command, the user can press 
<ENTER> or right click.

Finite Element Example (Continued)
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19.  or Thermal > FD/Fem Network > 
Element. 
The Command line should now read:
Select nodes for linear element 
or [MB]:

20. Select node 1, the node at the axis of 
the UCS icon.
The Command line should now read:
Select nodes for linear element 
or [MB]:

21. Select node 2, the node to the left of the 
first node.
The Command line should now read:
Select nodes for linear element 
or [MB]:

22. Select node 3, the node above the first 
node.
The Command line should now read:
Select nodes for linear element 
or [MB]:

23. Select node 4, the node to the right of 
the first node.
The Command line should now read:
Select nodes for linear element 
or [MB]:

24. Press <Enter> to end the selection pro-
cess.
Lines appear on the screen connecting 
the four nodes.

A quad element is being created from the 
four new nodes.

The order in which the nodes are picked 
is extremely important. Refer to the 
drawing below to select the nodes.

The order follows the right hand rule to 
determine which side is up. For example, 
picking the nodes in the order 1,2,4,3 
would produce a quad where the diago-
nals would cross. 

When the element is created, the view 
should be similar to the example below:

Finite Element Example (Continued)
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25. Select the new quad element to high-
light it.

26.  or Thermal > Edit.
The Thin Shell Data dialog box appears. 

27. Select the Cond/Cap tab. 
28. Click on the arrow next to the Material 

field and select Aluminum from the 
drop-down list. 

29. Select OK to close the dialog box.

The element is being edited to apply the 
material property created earlier.

The thickness does not matter since this 
element is used for an extrusion.

Finite Element Example (Continued)
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30. Select the new quad element.
31. Type ARRAYCLASSIC.

The Array dialog box appears.

32. Select Rectangular Array if not already 
selected (display a dot in the circle).

33. Highlight the current value in the Rows 
field and type 4 if a different value is 
displayed.

34. Highlight the current value in the Col-
umns field and type 3.

35. Highlight the current value in the Row 
Offset field and type 1 if a different 
value is displayed.

36. Highlight the current value in the Col-
umn Offset field and type 1 if a different 
value is displayed.

Note: The Row Offset and Column Offset 
fields display as 1.0000.

37. Select OK to close the dialog box.

38.  or View > Zoom > Extents.

This part of the exercise uses the Array 
command to create a 4x3 grid of quad 
elements. When completed, the model 
should look similar to the view below. 

Finite Element Example (Continued)
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39. Select Thermal > Model Checks > Show 
Free Edges.
The Command line should now read:
Select the elements for free edge 
calculations or [MB]:

40. Type all in the Command line.
The Command line should now read:
Select the elements for free edge 
calculations or [MB]:

41. Press <Enter>.
The grid lines turn red and the Com-
mand line area should show:
48 individual edges found

48 free edges found

The next steps use the Show Free Edges 
command to determine if these nodes are 
properly connected.

Once the Show Free Edges command is 
executed, notice that red lines cover the 
whole grid of the model. What has hap-
pened is that the Array command has 
copied the nodes as well as the elements 
and, therefore, the nodes are lying on top 
of each other. If the user output the 
model at this point (after resequencing 
the nodes), there would be no conduction 
between the elements.

Finite Element Example (Continued)
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42.  or Thermal > FD/Fem Network > 
Merge Coincident Nodes.
The Command line should now read:
Select nodes to be merged or 
[MB]:

43. Type all in the Command line.
The Command line should now read:
Select nodes to be merged or 
[MB]:

44. Press <Enter>.
The Merge Coincident Nodes dialog box 
appears. 

45. Highlight the current value in the Coin-
cidence Tolerance field and type .01.

46. Select OK to close the dialog box.
A Thermal Desktop/AutoCAD dialog box 
appears asking for confirmation of the 
merge.

47. Select Yes.

This group of steps merges the coincident 
nodes.

Finite Element Example (Continued)
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48.  or type regen in the Command line.
The array turns white.

49. Select Thermal > Model Checks > Show 
Free Edges.
The Command line should now read:
Select the elements for free edge 
calculations or [MB]:

50. Type all in the Command line.
The Command line should now read:
Select the elements for free edge 
calculations or [MB]:

51. Press <Enter>.
The outside edge of the array turns red.

52.  or type regen in the Command line.
The array turns white.

The regen command is performed here to 
clear the screen from the previous Show 
Free Edges and Merge Coincident Nodes 
commands.
The free edges are checked again and 
now only the outlying edges are drawn in 
red.

Finite Element Example (Continued)
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53. Select Thermal > FD/FEM Network > 
Extrude Planar Elements into Solids.
The Command line should now read:
Select Planar Elements/Edge Con-
ics for Revolve/Extrude or [MB]:

54. Type all in the Command line.
The Command line should now read:
12 found

Select Planar Elements/Edge Con-
ics for Revolve/Extrude or [MB]:

55. Press <Enter>.
The Command line should now read:
Select point to extrude from:

56. Type 0,0 in the Command line.
The Command line should now read:
Select point to define extrude 
vector/distance:

57. Type 0,0,5 in the Command line.
The Extrude/Revolve Planar Elements 
into Solids dialog box appears. 

58. Leave Even Breakdowns selected (dot in 
the circle).

59. Highlight the current value in the Solids 
Created along path field and type 5.

60. Select OK to close the dialog box.

The planar elements are extruded to 
make bricks. The vector given provides 
the distance of the extrusion.

Finite Element Example (Continued)
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61. Type zoom in the Command line.
The Command line should now read:
Specify corner of window, enter a 
scale factor (nX or nXP), or

[All/Center/Dynamic/Extents/Pre-
vious/Scale/Window/Object] <real 
time>:

62. Type extents in the Command line.
The view shifts to show the full array.

63. Type –vpoint in the Command line.
The Command line should now read:
Specify a view point or [Rotate] 
<display compass and tripod>:

64. Type -1,-1,0.9 in the Command line.
The view of the extruded model is 
rotated.

The view of the model is zoomed to the 
extents of the drawing area and then 
rotated a little bit to move the model off 
of the isometric view. The model should 
look similar to the view below. 

Finite Element Example (Continued)
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65.  or Thermal > FD/Fem Network > 
Hide Solid Interior Faces.
The view in the drawing area shifts.

Since the model was rotated off the nor-
mal, notice that there are many double 
lines that can be seen. These are the 
edges of the interior of the model. These 
lines can clutter up the model, especially 
if the model is the meshed.

The next step turns off these lines. By 
turning off these lines redisplays, rota-
tions, and post-processing of the model 
will process faster.

The calculation to hide the interior lines is 
only made when the user selects the 
command. Thus, if more geometry is 
added, or deleted, the user may need to 
re-execute the command to get the 
proper view. 

Finite Element Example (Continued)
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66. Select Thermal > FD/Fem Network > 
Revolve Planar Elements into Solids.
The Command line should now read:
Select Planar Elements/Edge Con-
ics for Revolve/Extrude or [MB]:

67. Type all in the Command line.
The Command line area should show:
12 found

Select Planar Elements/Edge Con-
ics for Revolve/Extrude or [MB]:

68. Press <Enter>.
The Command line should now read:
Select base point to revolve 
from:

69. Type -3,0 in the Command line.
The Command line should now read:
Select point to define revolve 
axis:

70. Type -3,3 in the Command line.
The Extrude/Revolve Planar Elements 
into Solids dialog box appears.

71. Leave Even Breakdowns selected.
72. Highlight the current value in the Total 

Distance field and type 90.
73. Highlight the current value in the Solids 

created along path field and type 9.
74. Select OK to close the dialog box.

These steps revolve the planar elements.

“All” can be used in the Command line for 
selection purposes since the nodes and 
the solids will be filtered out. Remember, 
only the bottom face has planar elements.

Finite Element Example (Continued)
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75.  or View > Zoom > Extents.
Use the Hide Interior Faces command to 
clean up the display as needed. The 
model should look similar to the drawing 
below. 

Finite Element Example (Continued)
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76. Select Thermal > Modeling Tools > 
Make AutoCAD group > From Thermal 
Objects.
The Command line should now read:
Select entities to make into a 
group or [MB]:

77. Type all in the Command line.
The Command line should now read:
Select entities to make into a 
group or [MB]:

78. Press <Enter>.
The Object Selection Filter dialog box 
appears. 

Leave the current selections as they 
appear: Surfaces/Planar Elements(12).

79. Select OK to close the dialog box.
The Group Name Input Form dialog box 
appears. 

80. Type plane in the Input Group Name 
field.

81. Select OK to close the dialog box.

The model now consists of planar element 
and solids. The planar elements must be 
deleted because their function is com-
plete.

The objects will be put into a group and 
then the AutoCAD Delete function to 
delete that group will be used.

Once all the object are selected, the filter 
appears and allows the planar objects to 
be filtered from the solids and nodes.

Finite Element Example (Continued)
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82.  or select Modify > Erase.
The Command line should now read:
Select objects:

83. Type group in the Command line.
The Command line should now read:
Enter group name:

84. Type plane in the Command line.
The Command line should now read:
Select objects:

85. Press <Enter>.

These steps will delete the planar ele-
ments. Note that the letter ‘g’ could be 
used instead of the word “group”.

Finite Element Example (Continued)
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86. Select Thermal > FD/Fem Network > 
Surface Coat Free Solid Faces.
The Command line should now read:
Select the solids for free face 
calculations or [MB GRP]:

87. Type all in the Command line.
The Command line should now read:
Select the solids for free face 
calculations or [MB GRP]:

88. Press <Enter>.
The Command line area should show:
0 free tri faces found

220 free quad faces found

and the Thin Shell Data - Multiple Sur-
face/Element Edit Mode dialog box also 
appears.

89. Review the Radiation tab.

90. Select the Cond/Cap tab.
91. Click on the arrow next to the Material 

field and select Aluminum from the 
drop-down list.

92. Select OK to close the dialog box.

Finite element solids must be surface 
coated to allow the definition of radiation, 
area contact or contactors, or insulation. 

The Surface Coat Free Solid Faces com-
mand will calculate all of the solid free 
faces and place a planar element on that 
face so that the active side is top.

When the Thin Shell Data dialog box 
opens the Radiation tab is active. The 
optical property DEFAULT is defined as a 
black-body: the emissivity and absorptiv-
ity are both unity.

The thickness of the planar element is set 
to zero so that it does not affect capaci-
tance and conductance calculations. With 
zero thickness the material properties will 
not be used, however, a material must 
still be selected since the material 
DEFAULT is undefined, unlike the optical 
property.

A Thermal Desktop/AutoCAD dialog box 
appears asking to confirm the change.

93. Select Apply Changes to close the dialog 
box.

Finite Element Example (Continued)
20-17



94. Select View > 3D Views > Front.
95. Type zoom in the Command line.

The Command line should now read:
Specify corner of window, enter a 
scale factor (nX or nXP), or 
[All/Center/Dynamic/Extents/Pre-
vious/Scale/Window/Object] <real 
time>:

96. Type .8x in the Command line.

Change the view to make it easier to 
select the nodes on the ends. The nodes 
will be selected and changed to boundary 
nodes. 

Finite Element Example (Continued)
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97. Select from points 1 to 2 as shown in 
Figure 20-21 and as noted below:
■ Using the example to the right as 

a guide, click the left mouse above 
the upper left corner of the sur-
face area (1).

The Command line should now read:
Command: Specify opposite cor-
ner:

■ Position the mouse on the oppo-
site, lower right corner of the 
selection area as shown in the 
example and click the left mouse 
button (point 2). Note that as the 
mouse is moved, a box is drawn 
around the area.

98.  or Thermal > Edit.
The Object Selection Filter dialog box 
appears.

99. Select Nodes[20] in the Select Type to 
filter field. 

100. Select OK to close the dialog box.

The nodes on the ends of the object must 
be edited. to apply the boundary tem-
peratures.

Refer to the example shown below 
(Figure 20-21) when selecting the nodes, 
starting the selection box at point 1. After 
the first point is selected, select point 2. 

When points 1 and 2 are selected, not 
only are the nodes selected but the sur-
face coated planar elements that were 
created earlier are also selected. When the 
Edit function is selected, the function 
determines that more than one type of 
entity has been selected. The Object 
Selection Filter dialog box is displayed. 

Note: The Object Selection Filter dia-
log box can also be displayed by 
selecting Thermal > Modeling 
Tools > Toggle Filter On.

Finite Element Example (Continued)
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The Node - Mulit Edit Mode dialog box 
appears. 

101. Click on Override calculation by ele-
ments/surfaces to place a check mark in 
the box.
The Type frame activates.

102. Click on boundary to place a dot in the 
circle.

103. Highlight the current value in the Initial 
temp field and type 373.15.

104. Select OK to close the dialog box.
A Thermal Desktop/AutoCAD dialog box 
appears asking for confirmation of the 
changes.

105. Confirm the changes to close the dialog 
box.

The selected nodes are changed to 
boundary nodes and the temperature is 
set. When nodes are part of an element 
(or surface), the definition of those nodes 
are obtained from the associated element 
(or surface). Overriding the calculation by 
the element (or surface) allows the user to 
provide a new definition for the selected 
node or nodes.

Finite Element Example (Continued)
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106. Select from points 3 to 4 as shown in 
Figure 20-22 and as noted below:
■ Click the left mouse at point 3 as 

shown in Figure 20-22.
The Command line should now read:
Command: Specify opposite cor-
ner:

■ Click the left mouse at point 4 as 
shown in Figure 20-22.

107.  or Thermal > Edit.
The Object Selection Filter dialog box 
appears.

108. Select Nodes[20] in the Select Type to 
filter field.

109. Select OK to close the dialog box.
The Node - Multi Edit Mode dialog box 
appears.

110. Click on Override calculation by ele-
ments/surfaces to place a check mark in 
the box.
The Type field activates.

111. Click on Boundary to place a dot in the 
circle.

112. Highlight the current value in the Initial 
temp field and type 273.15.

113. Select OK to close the dialog box. 
114. Confirm the changes to close the Multi 

Edit Dialog box.

Again, the selected nodes are changed to 
boundary nodes and the temperature is 
set. When nodes are part of an element 
(or surface), the definition of those nodes 
are obtained from the associated element 
(or surface). Overriding the calculation by 
the element (or surface) allows the user to 
provide a new definition for the selected 
node or nodes.

Finite Element Example (Continued)
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115.  or select Thermal > Modeling 
Tools > Resequence IDs.
The Command line should now read:
Select entity(s) for Node ID 
Resequencing or [MB GRP]:

116. Type all in the Command line.
The Command line should now read:
Select entity(s) for Node ID 
Resequencing or [MB GRP]:

117. Press <Enter>.
The Resequencing Node IDs dialog box 
appears. 

118. Leave the default values and select OK 
to close the dialog box.
The Command line area should show:
300 nodes were changed

This part of the exercise resequences the 
node IDs so all nodes have a unique num-
ber.

Finite Element Example (Continued)
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119.  or Thermal > Case Set Manager.
The Case Set Manager dialog box 
appears. 

120. Click on Edit.

The Case Set Manager is the link from 
Thermal Desktop to SINDA/FLUINT. The 
Case Set Manager allows the user to set 
up different thermal analysis cases, each 
with its own radiation calculations and 
parameters. Once the cases are defined, 
the user can create SINDA models, run the 
analyses, and post-process the results 
with the click of a single button.

Once parameters are set and the Run 1 
Selected Case button is clicked, Thermal 
Desktop will calculate any radiation con-
ductors and heating rates for all of the 
tasks set up for the current Case Set. 
Nodes and conductors are then computed 
and output. A SINDA/FLUINT model is 
then built and run. And finally, the tem-
perature results are displayed mapped 
onto the thermal model in color.

Editing a case allows the case to be 
defined beyond the default settings.

Finite Element Example (Continued)
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The Case Set Information - Case Set 0 
dialog box appears. 

121. Examine the tabs and the information 
on each tab, but do not change anything 
at this time.

122. Select OK to close the dialog box.
The Case Set Manager dialog box reap-
pears.

123. Click on Run 1 Selected Case.
The Case Set program is run.
When complete, the graphic output 
appears in the drawing area. the SINDA/
Fluint Run Status dialog box appears on 
top of the graphic output confirming 
successful completion of the process.

124. Select OK to close the dialog box.

By selecting OK, the case is allowed to use 
the default settings: no radiation with a 
steady state analysis. Although Calculate 
Radiaiton is checked, not radiation tasks 
were set up.

Selecting Run 1 Selected Case will allow 
the Case Set Manager to output the con-
ductors and capacitance, build the SINDA 
model, solve the SINDA model, and dis-
play the steady state temperatures back 
on the model.

Finite Element Example (Continued)
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125. Select View > 3D Views > Front.

126. Select File > Save Save the model before adding radiation.

If you have access to a RadCAD license, you may continue; otherwise, skip ahead to 141 Select 
File > Exit..

Finite Element Example (Continued)
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127.  or Thermal > Case Set Manager.
The Case Set Manager dialog box 
appears.

128. Click on Copy.
The Add New Case Set dialog box 
appears.

129. Type Radiation for the New Case Set 
Name

130. Select OK to close the dialog box.
The Case Set Manager dialog box reap-
pears.

131. Select Radiation Case Set and click on 
Edit.
The Case Set Information - Radiation 
dialog box appears.

132. Select the Radiation Tasks tab, if it is not 
already selected.

133. Select the Add button.
The Radiation Analysis Data dialog box 
appears.

134. Confirm Radks is selected in the Calcu-
lation Type region.

135. Confirm BASE is in the Analysis Group 
field.

136. Confirm Monte Carlo is selected in the 
Calculation Method region.

137. Select OK to close the dialog box.
The Case Set Information - Radiation 
dialog box reappears.

138. Select OK to close the dialog box.
The Case Set Manager dialog box reap-
pears.

139. Click on Run 1 Selected Case.
The Case Set program is run.
When complete, the graphic output 
appears in the drawing area. the SINDA/
Fluint Run Status dialog box appears on 
top of the graphic output confirming 
successful completion of the process.

140. Select OK to close the dialog box.

An Analysis Group is a user-defined 
group of objects which will exchange 
energy though radiation. The group BASE 
is a default and all surfaces are included 
unless otherwise specified.
To learn more about Analysis Groups 4.1 
Radiation Analysis Groups. To learn more 
about radiation analyses and calculations 
10.1 Radiation Calculations and Output to 
SINDA/FLUINT.
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The radiation calculation includes a sink temperature of 2.73 K by default, explaining the 
cooler temperatures.

141. Select File > Exit.
A Thermal Desktop/AutoCAD dialog box 
appears asking if the user wants to save 
the changes made to the drawing.

142. Select Yes.
The drawing is saved and Thermal 
Desktop closes.

Exit Thermal Desktop.

Note: Be sure to save the changes to 
the file since it will be used as a 
starting point for another tutorial.

Finite Element Example (Continued)
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20.7 Mapping Temperatures From a Coarse Thermal Model to a 
Detailed NASTRAN Model

What will be learned:

■ Importing a finite element mesh created outside of Thermal Desktop.
■ Mapping temperatures from a Thermal Desktop model to another type of model.

Prerequisites:

■ 20.2 Setting Up a Template Drawing

This tutorial maps temperatures from a coarse model of a plate with two holes in it to a dif-
ferent mesh of the same model that has much finer detail. This situation is very common 
when the stress analyst has a very detailed model for a part, but the thermal model must be 
made coarse so as to get the part integrated into the entire thermal model.

CRTech would like to give a special thanks to Jim Braley for providing the sample NASTRAN 
models for this tutorial. 

Mapping Example 

1. Copy the template thermal.dwg file created in the first tutorial to the \Tutori-
als\Thermal Desktop\mappingExample directory.

Note: Be sure to hold the <Ctrl> key down if dragging the template file icon to the new 
directory so that the file is copied, rather than moved.

In addition to the copied template drawing, there are two existing files in the map-
pingExample folder:
■ coarse_quad.nas
■ fine_quad.nas. 

The two files will be imported into the model during the exercise.
2. Rename the copied template file to coarse.
3. Start Thermal Desktop by double clicking on the coarse drawing file icon in the map-

pingExample directory.

4. Select View > 3D Views > Top.
The UCS icon reflects the new orienta-
tion.

Change the view in the drawing area to 
the top view.
20-1



5. Select Thermal > Import > Create FE 
Mesh Importer.

6. The FE Mesh Importer dialog box 
appears.

7. Change the input file name to be 
coarse_quad.NAS.

8. Change the submodel to MAIN.
9. Select OK to close the dialog box.

The next step imports the 
coarse_quad.NAS file into the drawing. 
When the import process is complete, a 
model of a plate with two holes in it will 
be displayed.

The model should look similar to the 
example below. 

Mapping Example  (Continued)
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10. Select Thermal > Preferences
11. Select Graphics Visbility tab
12. Check the TD/RC Nodes box
13. Select OK to close the User Preferences 

dialog.

14. Select the nodes on the left edge of the 
model by drawing a selection box from 
points 1 to 2, as shown in the example 
to the right.

Note: In this case, selection order is not 
important in that only the nodes are to be 
selected rather than the nodes and any 
other objects that may be partially 
enclosed by the selection box. Remember 
that selecting objects from top to bottom 
will only select those items fully enclosed 
by the selection box whereas selecting 
objects from bottom to top will include 
items not fully enclosed by the selection 
box into the selection set.

15.  or Thermal > Edit.
The Node - Mulit Edit Mode dialog box 
appears. (next page)

Some boundary conditions must be cre-
ated so the model can be run and some 
gradients obtained. The nodes on the left 
edge of the model are to be designated as 
boundary nodes. 

16. Select Override calculations by ele-
ments/surfaces to place a check mark in 
the box.

The Type fields activate.

17. Select boundary (place a dot in the cir-
cle). 

18. Select OK to close the dialog box.
A Thermal Desktop/AutoCAD dialog box 
appears asking for confirmation of the 
node changes.

19. Confirm the changes to close the dialog 
box.

The node shapes change to show their 
new designation

Mapping Example  (Continued)

1

2

20-3



20. Select the nodes on the right edge of the 
model by drawing a selection box from 
points 3 to 4, as shown in the example 
to the right.

Note: As in the selection of the nodes on the 
left edge, selection order (top to bottom 
versus bottom to top) is not important in 
this case as only the nodes on the right 
edge are being selected in this step.

21.  or select Thermal > FD/Fem Net-
work > Heat Load on Nodes.
The Heat Load Edit Form dialog box 
appears. 

22. Highlight the current value in the Heat 
Load [W] Value field and type 10.

23. Select OK to close the dialog box.

A heat load of 10 watts is to be applied to 
the nodes on the right edge of the model. 

Note: Because of the top view of the 
model, once the heat load has 
been applied it appears the nodes 
change color from green to red. If 
the model is rotated to look at 
from another angle, small red 
arrows are displayed which give 
the illusion of the red nodes from 
the top view. 

If the model is rotated back to a 
top view, the nodes appear white 
in color again, with small spots of 
red.

Mapping Example  (Continued)
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24.  or Thermal > Case Set Manager.
The Case Set Manager dialog box 
appears. 

25. Click on Edit.
The Case Set Information dialog box 
appears.

Use the Case Set Manager to process a 
steady state solution on the problem.

The primary purpose of the Case Set 
Manager is to allow the user to set up dif-
ferent thermal analysis cases and to have 
the calculations made: from doing radia-
tion calculations to creating and running 
the SINDA model to post-processing 
temperatures with the click of a single 
button. When the Run 1 Selected Case 
button is clicked, Thermal Desktop will 
first calculate the radiation conductors 
and heating rates for all of the tasks set 
up for the current Case Set. Nodes and 
conductors are then computed and out-
put. A SINDA model is then built and run. 
And finally, the temperature results are 
displayed mapped onto the thermal 
model in color.

The user may set up different Case Sets to 
be steady state or transient analyses. Each 
Case Set may have different start and stop 
times for transient runs. The user can also 
have different SINDA Logic, property 
databases or aliases, or even different 
symbol values 

Mapping Example  (Continued)
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26. Click on the Calculations tab. 

Steady State in the Solution Type field is 
already selected.

27. Select OK to close the dialog box and 
return to the Case Set Manager dialog 
box.

28. Click on Run 1 Selected Case.

Mapping Example  (Continued)
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The solution is processed. When complete, the data displays on the screen along with 
a SINDA/FLUINT Run Status dialog box confirming successful completion of the run. 

29. Click on OK to close the dialog box. 

Mapping Example  (Continued)
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30. Select Thermal > Export > Post Process-
ing Data Mapper.
The Mapper PP to XYZ Input File dialog 
box appears. 

31. Choose NASTRAN in the Format field.
32. Choose fine_quad.nas in the Input File 

field drop down menu.
33. Ensure that Use World Coordinate Sys-

tem (WCS) is selected

The stress analyst has added a more 
detailed model titled fine_quad.nas. and 
needs the temperatures for the nodes in 
this model in order to perform thermal 
stress calculations.

The Map Object allows the Thermal Desk-
top user to preview the stress model in 
side Thermal Desktop, align the two 
models, and map the postprocessed data 
to the stress model.

The available format options are NAS-
TRAN, ANSYS, FEMAP, and I-deas.

The user may choose to browse if the 
desired input file is not in the current 
directory.

The user may choose to align the stress 
model to the World Coordinate System 
(WCS) or the User Coordinate System 
(UCS)

Mapping Example  (Continued)
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34. Select OK to close the dialog box.
The Post Processing Data to XYZ Mapper dialog box appears.

35. Highlight the current value in the Output 
File field and type temps.out.

36. Select Exit & Map to close the dialog box 
and map the data.

The Use Advanced Mapping option auto-
matically finds the best mapping. If more 
than one object is found for a location, 
then a notice will be provided if the tem-
perature difference is greater than the 
Track Multi Map Temp Dif value.

The user can choose to map the data 
immediately using Exit & Map, or may 
simply Exit to manipulate the mapper 
graphical object (e.g. align the mapper to 
the thermal model)

The file temps.out contains mapped temperatures in the format necessary for them to be 
included into the Stress model. The engineer must cut and paste these into the proper place in 
the NASTRAN model in order to perform the thermal stress calculations.

Mapping Example  (Continued)
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37.  or Thermal > Model Browser.
The Model Browser window appears on 
the left side of the screen.

38. Choose List>Mesh Displayers/PP Map-
pers/BCM/Cutting Planes from the 
Model Browser menu bar.

39. Select MapperPP from the Mesh Display-
ers tree.

40.  or Display > Turn Visibility Off.
The mapper turns off and the coarse 
finite element model is visible. Note the 
shape of the contours and the holes.

41.  or Display > Only on the Model 
Browser menu bar. 
The finite element model has been 
turned off (notice the nodes are gone) 
and the mapper is turned back on. Note 
that the shape of the holes has been 
refined, but the contours are the same.

After mapping is complete, the mapped 
data is displayed on the mapper. Any 
locations in the external file (the stress 
model) that did not get mapped will be 
displayed as grey.

Mapping Example  (Continued)
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42. Select File > Exit.

Note: Thermal Desktop can also be exited 
using the Windows Close button (X) in the 
upper right corner of the screen.

A Thermal Desktop/AutoCAD dialog box 
appears asking to save the drawing 
changes.

43. Select Yes.

Mapping Example  (Continued)
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20.8 Contactor Example

What will be learned:

■ Using the Model Browser
■ Using layers to control object visibility
■ Using edge Contactors
■ Using face Contactors
■ Using material-based Contactors
■ Checking contactors
■ Using Symbols and Expressions

This tutorial demonstrates some of the capabilities of Thermal Desktop’s Contactors. The 
example model is a pipe with circular, plate fins and a small block-shaped sensor. The plate 
fins will be connected to the pipe by edge contactors that could represent a braze or weld. 
The sensor is connected to the pipe by an area contactor that could represent a gasket or 
insulation.

Contactors, like contact created with the contact tab in the object edit window, are used to 
thermally connect two objects. However, contactors provide more functionality than contact 
such as: 

■ allowing a gap between the objects being connected
■ allowing material, radiation, one-way, and insulation defined connections
■ allowing the user to select which objects will be included in the connection tests.

Note: This tutorial is meant to show different capabilities of contactors. To accomplish 
this, the best modeling options may not have been used. For example, using solid disks 
(with only one subdivision in the thickness direction) instead of planar disks for the fins 
would have eliminated having to specify the thickness of the fin for the contactor, but 
would have eliminated the practice with edge contactors.
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Contactor Example 

1. Double click on the file Contactors.dwg located in the Tutorials\Thermal Desk-
top\Contactors folder.
Thermal Desktop opens with the Contactors drawing on the screen. 

Figure 20-28:
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2.  or Thermal > Model Browser.
The Model Browser window appears on 
the left side of the screen. 

3. Using the Model Browser menu bar click 
on LIST to confirm that Surfaces/Solids 
is selected (check mark).

4. If necessary, expand the Main tree by 
clicking on the + sign in front of the 
folder.

5. Click on FD Brick-Sensor.

6.  or Display > Turn Visibility Off in 
the Model Browser toolbar.

7. Minimize the Model Browser window or 
move so it does not block the drawing.

8. Press <ESC> to be sure the selection set 
is clear.

Use model browser to set selection 
options and turn off objects that will not 
be modified during upcoming steps.

The drawing should now appear similar to 
the view below:

Contactor Example  (Continued)
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9.  or Thermal > FD/FEM Network > 
Contactor. 
The Command line should now read:
Select faces contacting from or 
[MB]:

10. Select each of the four fins in the draw-
ing area.
The Command line should now read:
Select faces contacting from or 
[MB]:

11. Press <ENTER>.
The Command line should now read:
Select surfaces contacting to or 
[MB]:

12. Select the pipe in the drawing area.
The Command line should now read:
Select surfaces contacting to or 
[MB]:

13. Press <ENTER>.
The Contactor dialog box appears. (next 
page)

14. Type Fins to pipe in the comment field.
15. From the drop-down list in the Contact 

From field select Edges.
16. Select the Use Material check box.

The Use Material field becomes active.
17. From the drop-down list in the Use 

Material field select Aluminum, 2024-
T6.

Create edge contactors to thermally con-
nect the fins to the pipe. The connection 
is assumed to be an aluminum weld of 
thickness WeldThickness.

Important: Contactors do not cal-
culate the conductance from the 
node to the edges of surfaces 
connected by contactors. There-
fore, that conductance should be 
included in the contactor coeffi-
cient or the better method is to 
use edge nodes. In this model, 
edge nodes are used for the fins 
and sensor. 

Important: In most cases, surfaces 
with smaller nodal areas should be 
chosen as the From surfaces. All 
integration points on a From sur-
face are used in the testing algo-
rithm.

Contactor Example  (Continued)
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18. Double click in the Coeff field.
The Expression Editor dialog box 
appears.
Using right-click to select the symbol 
names from the general list, enter the 
following expression in the expression 
field:

FinThickness/WeldThickness

19. Click OK to close the dialog box.
The Contactor dialog box updates to 
show 6 in the Coef field in bold type.

The SINDA conductor value resulting from 
a contactor is either kA/L, hA, or a Radk 
(i*Bij*Ai). When Use Material is selected 
for an edge contactor, the conductivity is 
obtained from the chosen material prop-
erty and the length of the surface edge is 
taken from the geometry. Therefore, to 
complete kA/L, the Coeff value must be 
the thickness of the edge (FinThickness) 
divided by the distance in the direction of 
the heat flow (WeldThickness).

To see definitions of the symbols being 
used, select the Add Symbol button while 
in the Expression editor.

Contactor Example  (Continued)
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20. Select all four fins in the From: field.

21. Edit From Object icon at the bottom 
of the Contactor dialog box.

22. The Select Edges dialog box appears.

23. Select the Deselect All button
24. Check Min Radius so the box is checked.
25. Click OK to close the dialog box.

The Contactor dialog box updates to 
show Min Radius beside each object in 
the From field.

26. Click Show Calcs to close the Contactor 
dialog box and show the contactor 
markers.

When the Contactor dialog box closes, the 
graphical image for the contactors are 
displayed:

■ The from surfaces have green 
arrows on the edges (or faces) 
included in the contactor.

■ The to surfaces have gold 
arrows at the centroid of each 
face.

Contactor Example  (Continued)

Figure 20-29:

From

To
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Yellow lines connecting the edges of the 
disks to nodes of the pipe appear. 

Changing to wireframe, , will make 
the markers more visible.

27.  toggles node visibility on.

28.  or Thermal > Model Checks > Clear 
Contact/or Markers
The contactor markers are cleared.

29.  toggles node visibility off.

Use contactor markers to verify connec-
tion of the Fins to Pipe contactor.

The contactor markers connect the inte-
gration points of the From edges to the 
nodes of the To surfaces.

Note: If the Coef field is 0, then the 
contactor markers will not be 
drawn.

Ten contactor markers are drawn from 
the inner edges of each fin (Figure 11-
58). The markers show which integration 
points have met the requirements of the 
testing algorithm. Any integration point 
not within the tolerance of the To surface 
would be marked with a red cross.

When nodes are visible, note that not all 
pipe nodes are connected, but all inner 
edges of the fins are connected. Also note 
that To surface nodes can be connected 
multiple times, but test points are con-
nected only once.

Contactor Example  (Continued)

Figure 20-30: Contactor markers
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30. Restore the Model Browser Window.
31. Select the four fins in the Model Browser 

tree.

32.  Turn Visibility Off icon in the Model 
Browser toolbar.
The disks representing the fins disap-
pear from the graphics window.

33. Select the Sensor.

34. Turn On Visibility icon in the Model 
Browser toolbar.
The brick representing the sensor 
appears in the graphics window.

35. Right-click the sensor and choose Send 
Selection Set to AutoCAD.

36.  or Thermal > FD/FEM Network > 
Contactor. 
The Command line should now read:
Select surfaces contacting to or 
[MB]:

37. Type MB
A new Model Browser window opens.

38. Select Cylinder-Pipe and close the new 
Model Browser Window.
The Command line should now read:
1 object selected

1 added

1 found

Select surfaces contacting to or 
[MB]:

39. Press <ENTER>.
The Contactor dialog box appears.

Create area contactor to thermally con-
nect the sensor to the pipe. The connec-
tion is a per-area coefficient.

The Model Browser typically minimizes to 
the upper left corner of the display.

The Contactor command accepts prese-
lected items (the sensor in this case) as 
the from object(s) and moves on to 
selecting To surfaces.

The MB option allows selection from a 
model browser window. Whatever is 
selected when the newly opened Model 
Browser is closed is added to the selection 
set.

Contactor Example  (Continued)
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40. Type Sensor to pipe in the comment 
field.

41. Highlight the current value in the Toler-
ance field and type 0.008.

42. Highlight the current value in the Con-
duction Coefficient field and type 5.

43. Choose Ray Trace Algorithm in the 
Inputs for Connection Algorithm Sec-
tion.

For the ray trace algorithm, a ray of length 
Tolerance is shot normal to the From sur-
face at each test point. If the ray inter-
sects with a To surface, the ray terminates 
and a connection is made.

By contrast, the point algorithm checks 
for surfaces within tolerance in all direc-
tions.

44. Double-click the sensor in the From 
field.

45. Deselect all check-boxes except YMAX.
46. Select OK to close the Select Faces dia-

log.
47. Select Show Calcs to close the Contactor 

dialog box and show the contactor 
markers.
A text window will appear showing that 
the contactor did not make 100% con-
nection due to the tolerance used.
The contactor markers will show gold 
(connected) and red (outside of toler-
ance).

48. Close the text window.

The contactor is limited to only the side 
where the actual contact is made. Using 
ray tracing and tolerance would also elim-
inate the non-contact sides, but calcula-
tion time would be required to determine 
this. Selecting only certain sides, prevents 
unnecessary calculations.

Use contactor markers to verify connec-
tion of the Sensor to Pipe contactor.

Contactor Example  (Continued)
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49. View > 3D Views > Top.
The markers can be seen more easily.

50.  or Thermal > Model Checks > Clear 
Contact/or Markers
The contactor markers are cleared.

51. View > 3D Views > SW Isometric.
52. Restore the Model Browser Window.

53. Display All icon in the Model 
Browser toolbar.
The fins appear in the graphics window.

54. Minimize the Model Browser window.

When the view is changed to Top, the 
graphics display should look like this:

Since the ray trace algorithm was chosen, 
the markers appear as rays normal to the 
From surface. Test points that are not 
within the tolerance are shown in red.

Contactor Example  (Continued)
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55. Using the Layer Drop Down Menu, select 
boundary as the current layer.
The Layer Drop Down Menu originally 
says Objects and is located next to the 

 button. The drop down menu is 
accessed by clicking on the down-arrow 
to the right of the word Objects.

56.  or Thermal > Surfaces/Solids > 
Rectangle
Origin point <0, 0, 0> appears in 
the Command Line area.

57. Type -0.1,0,0 in the Command Line, 
then return.
Point for +X and X-size <@1, 0, 
0> appears in the Command Line area.

58. Type @0.01,0,0 in the Command Line 
then return.
Point to set XY plane and Y-size 

<@0,1, 0> appears in the Command 
Line area.

59. Type @0,0.01,0 in the Command Line 
then return.
The Thin Shell Data dialog box appears.

60. On the Numbering tab, type AMBIENT 
into submodel.

61. Click on the Cond/Cap tab.
62. Select AMBIENT for Cond Submodel.
63. Click on Generate Cond/Cap button to 

open the Expression Editor
64. Type 0 into the Expression.
65. Click OK to close Expression Editor.

Create a small surface to represent the 
ambient air so contactors can be created 
from the fins to the air.

Ambient conditions will typically be rep-
resented by a user defined node, but con-
ductors between nodes and surfaces do 
not allow edge conduction. Therefore, a 
small surface will be created to represent 
convection from the edges of the fins and 
allow a contactor.

Other options would be to use FD Solid 
Cylinders for the fins or ignore the con-
vection from the edge of the fin.

A value of zero in the expression prevents 
the surface properties from being gener-
ated for a SINDA file.

If radiation analyses were to be per-
formed, “Not in analysis group” should be 
selected for all analysis groups.

66. Click OK to close the Thin Shell Data 
dialog box.

67.  or View > Zoom > Extents

Contactor Example  (Continued)
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68. Restore the Model Browser Window.
69. Choose List By > Submodel.ID
70. Right-click AMBIENT and select Edit
71. In the Object Selection Filter, select 

Nodes(1) and OK.
72. Select Override calculations by ele-

ments/surfaces (place a check mark in 
the box).

73. Select Boundary (place a dot in the cir-
cle).

74. Type Ambient in the Comment field.
75. Double-click in the Submodel field to 

highlight MAIN.
76. Type AMBIENT into the Submodel field.
77. Select OK to close the dialog box.

Override the surface node to create a 
boundary node. If User Node Visibility is 
on, a triangle appears at the center of the 
surface. Even though the ambient node 
will not be generated as part of the sur-
face, it will now be generated as a user 
node.

Contactor Example  (Continued)
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78.  or Thermal > FD/FEM Network > 
Contactor. 
The Command line should now read:
Select faces contacting from or 
[MB]:

79. Select all four fins in the drawing area.
The Command line should now read:
Select faces contacting from or 
[MB]:

80. Press <ENTER>.
The Command line should now read:
Select surfaces contacting to or 
[MB]:

81. Select the newly created small surface in 
the drawing area.
The Command line should now read:
Select surfaces contacting to or 
[MB]:

82. Press <ENTER>.
The Contactor dialog box appears.

83. Type Fin faces to ambient in the com-
ment field.

84. Highlight the current value in the Con-
duction Coefficient field and type 50.

85. Select all four fins in the From: field.

86. Edit From Object icon near the bot-
tom of the Contactor dialog box.
The Select Faces dialog box appears.

87. Select both top and bottom (check 
marks should be in both boxes).

88. Click OK to close the dialog box.
89. Click Show Calcs to close the Contactor 

dialog box and display the contactor 
markers.

Create convection from faces of fins using 
contactors.

Note new Contactor graphical objects 
when complete.

Here the order of selecting From and To is 
important. The area of the contact is cal-
culated using the From surfaces.

Contactor Example  (Continued)
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90. Read the warning message that appears. 
This is not a problem in this situation 
since the fin surface areas are needed 
and the area of the boundary surface is 
not used.

91. Close the Warning window.
92. View > 3D Views > Front.

93.  or Thermal > Model Checks > Clear 
Contact/or Markers
The contactor markers are cleared.

94. View > 3D Views > SW Isometric.

Use contactor markers to verify connec-
tion of the Fin faces to Ambient contactor.

Notice the separation between the ends of 
the contact markers and the fins in the 
view below:

This happens because the test points are 
allowing for the thickness of the fins.

Contactor Example  (Continued)

Figure 20-31: Contactors with surface 
thickness

Fin

Markers
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95.  or Thermal > FD/FEM Network > 
Contactor. 
The Command line should now read:
Select faces contacting from or 
[MB]:

96. Select all four fins in the drawing area.
The Command line should now read:
Select faces contacting from or 
[MB]:

97. Press <ENTER>.
The Command line should now read:
Select surfaces contacting to or 
[MB]:

98. Select the small surface in the drawing 
area.
The Command line should now read:
Select surfaces contacting to or 
[MB]:

99. Press <ENTER>.
The Contactor dialog box appears.

100. Type Fin edges to ambient in the com-
ment field.

101. From the drop-down list for the Contact 
From field select Edges.

102. Double-click in the Conduction Coeffi-
cient field.
The Expression Editor dialog box 
appears,

103. Right-click to select the symbol names 
in the general list and enter the follow-
ing expression in the Expression field

FinThickness*50

104. Click OK to close the dialog box.
The Conduction Coefficient field now 
shows 0.3.

Create convection from edges of fins 
using contactors.

Again, the From objects are used for the 
geometry. For an edge contact, the length 
of the edge is calculated so the thickness 
of the edge must be included in the coef-
ficient.

Contactor Example  (Continued)
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Running the model requires a heat load or a fixed boundary temperature (different than the 
boundary node already defined). The user can add a heat load to the pipe surface or change 
the pipe nodes to boundary nodes and obtain a solution. The node IDs must also be rese-
quenced.

If the user runs a transient solution, the time step taken by SINDA/FLUINT will likely be very 
small. This is caused by the large conductance at the base of the fins: G = k*A/L. If the user 
adds a factor to the coefficient of the fin-to-pipe contactor, he or she can see how the con-
ductance of the contactor can affect the solution time step.

105. Select all four fins in the From: field.

106. Edit From Object icon.
The Select Edges dialog box appears.

107. Deselect all checked boxes.
108. Select Max Radius so the box is 

checked.
109. Click OK to close the dialog box.
110. Click OK to close the Contactor dialog 

box.

111. Select File > Exit.
A Thermal Desktop/AutoCAD dialog box 
appears asking to save the drawing 
changes.

112. Select Yes.

Exit Thermal Desktop and save as 
prompted.

Contactor Example  (Continued)
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20.9 Parameterizing for a Common Input

What will be learned:

■ Inserting a model into another drawing file
■ Importing and renaming symbols

Prerequisites:

■ 20.2 Setting Up a Template Drawing

Sometimes it is common that the same geometry is used over and over in the same model. 
This geometry can be as simple as a five or six-sided box or can be much more complicated. 
In this example, a simple five sided-box with centered nodes that has conductors between 
each of the faces has been created. The geometry has been parameterized so that the user 
can simply change the x, y, and z sizes so that the box will automatically update when the 
user changes the symbols.

Parameterized Box Example

1. Double click on the file box.dwg located in the Tutorials\Thermal Desktop\Parame-
terized Box For Insert folder.
Thermal Desktop opens with the drawing on the screen. 
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2. Select Thermal > Symbol Manager.
The Symbol Manager dialog box 
appears.

3. Select Done to close the dialog box.

Take a few moments to examine the 
model.

Bring up the Symbol Manager. Notice the 
parameters for x, y, and z sizes. There is 
also a parameter for the thickness of the 
faces on the box.

4. Click on the top of the box to select it.

5.  or Thermal > Edit.
The Thin Shell Data dialog box appears.

6. Select the Surface tab. 
7. Look at the X Max and Y Max fields.

Look at some of the data that make up 
the top of the box. After selecting the top, 
utilize Thermal Desktop’s Edit function to 
display the Thin Shell Data dialog box.
Notice the lengths of the X and Y axes are 
parameterized (Surface tab) and that the Z 
translation is also programmed (Trans/
Rot tab).

Take a moment to select some of the 
other surfaces and conductors to get an 
idea of how they are programmed.

8. Select the Trans/Rot tab. 
9. Look at the Translation Z field.
10. Select OK to close the dialog box.
11. Repeat the process for some of the 

other surfaces and conductors as 
desired.

12. Select File > Exit.
A Thermal Desktop/AutoCAD dialog box 
appears asking to save the drawing 
changes.

13. Select Yes.

Close box.dwg saving it to the current 
AutoCAD version and exit Thermal Desk-
top.

14. Copy the template thermal.dwg file created in the first tutorial to the \Tutori-
als\Thermal Desktop\Parameterized Box For Insert directory.

Note: Be sure to hold the <Ctrl> key down if dragging the template file icon to the new 
directory so that the file is copied, rather than moved.

15. Rename the copied template file to parameter.
16. Start Thermal Desktop by double clicking on the parameter drawing file icon in the 

Parameterized Box For Insert directory.

Parameterized Box Example (Continued)
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17. Select Insert > Block.
The Insert dialog box appears. 

18. Select Browse.
The Select Drawing File dialog box 
appears with two drawings displayed in 
the drawing field.

19. Select box.dwg to highlight it.
20. Select Open.

The Insert dialog box reappears with 
box displayed in the Name field.

21. Select Specify On-Screen in the Insertion 
field (place a check mark in the box) if 
not already selected. 

22. Check Explode
23. Select OK to close the dialog box.

The Command Line should now read:
Specify insertion point or [Base-
point/Scale/X/Y/Z/Rotate]:

24. Click at any point on the screen to place 
the box. (Some versions of AutoCAD 
may prompt for scaling factors at this 
point)
A close view of a box corner appears in 
the drawing area.

Bring the box drawing into the template 
copy.

Each user will have a somewhat different 
image appear in the drawing area because 
of the insertion point selections but, in 
general, the drawing should appear simi-
lar to the drawing below once zoomed 
extents is performed. 

Parameterized Box Example (Continued)
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25.  or Zoom > Extents.
26. Click on the top of the box.

Notice that only the top is selected. 
27. Select other surfaces as desired and 

press <Esc> to deselect when finished.

If the entire box is selected then the block 
was not exploded. Explode the box so 
that it is no longer an AutoCAD Block, but 
individual Thermal Desktop entities. Just 
type EXPLODE when the entire box is 
selected.

Once Explode is performed, individual 
components of the box can be selected 
rather than only the whole box.

28. Select Thermal > Symbol Manager.
The Symbol Manager dialog box appears 
and the dialog box’s fields are empty.

29. Select Import.
The Open dialog box appears.

30. Select box.dwg to highlight it and then 
select Open.
The Import dialog box appears.

31. Select thickbox, xbox, ybox and zbox 
and select Import.
The Symbol Manager dialog box reap-
pears with the symbols displayed. 

Use the Symbol Manager Import com-
mand to import the file boxSymbols.sym. 
Xbox, ybox, zbox and thickness symbols 
are imported.

Symbols can be exported into SYM files 
from the symbol manager. Symbols can 
be imported either from a SYM file or 
directly from a DWG file.

Parameterized Box Example (Continued)
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32. Select the 4 symbols:
■ Click on thickbox to highlight it and 

then, hold down the <Shift> key and 
click on zbox.

33. Select Rename on the right side of the 
form.
The Multiple Rename dialog box 
appears.

34. Select the radio button beside Append 
String to each existing string.

35. Type _1 in the Append string field. 

36. Select OK.
The Symbol Manager dialog box reap-
pears displaying the new symbol names. 

The box is to be imported multiple times, 
so the imported symbols must be 
renamed. Append _1 (underscore 1) to 
each of the symbol current names.

Parameterized Box Example (Continued)
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37. Select xbox_1.
38. Select Edit.

The Expression Editor dialog box 
appears with the current xbox_1 infor-
mation.

Note: Double clicking on a symbol also dis-
plays the Expression Editor.

39. Highlight the current value in the 
Expression field if not already high-
lighted and type 10.

40. Select OK.
The changed parameters for xbox_1 are 
reflected.

41. Repeat the process for ybox and zbox, 
changing the values to 1/10 of the cur-
rent value.
The Symbol Manager dialog box dis-
plays the new values.

42. Select Done to close the Symbol Man-
ager dialog box.

Edit the symbols for xbox, ybox, and 
zbox to be one tenth of their original val-
ues.

The box changes in the drawing area to 
reflect the changes in size. 

43. Select Insert > Block.
The Insert dialog box appears with box 
in the Name field highlighted. 
Specify On-Screen in the Insertion field 
is already selected from the previous 
insertion.

44. Select OK to close the dialog box.
A box is attached to the cursor waiting 
for insertion.
The Command Line should now read:
Specify insertion point for 
block:

45. Click at any point on the screen to place 
the new box. 
The new box appears on the screen. 
Notice the difference in the sizes of the 
two boxes—the first box’s size was 
changed to 1/10 of its original size 
(xbox_1).

Insert another box. Use the Insert > Block 
command, but this time it is not neces-
sary to reselect the box.dwg file, simply 
change the Name: pull down to box and 
select OK.

Select any point on the screen to place the 
box, and then explode the box. 

Once the second box is inserted, explode 
it so the individual entities.

Parameterized Box Example (Continued)
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46. Click on various parts of the box as 
desired to confirm “explosion” and press 
<Esc> when finished.

47. Select Thermal > Symbol Manager.
The Symbol Manager dialog box reap-
pears with the symbols renamed earlier 
displayed.

48. Right-click the general tab and select 
Add New Group to create a new Symbol 
Group. 

A new tab named group1 is displayed.
49. Click on the general tab. 

50. Select all 4 symbols.
51. Select Edit.

The symbols listed in the Symbol Manager 
belong to a group named general. Add a 
second symbol group named group1.

Parameterized Box Example (Continued)
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The Symbol Edit - Multi Edit Mode dialog 
box appears. 

52. Click on the arrow next to the Group 
field and select group1 from the drop-
down list. 

53. Select OK to close the Symbol Edit - 
Multi Edit Mode dialog box.
The Symbol Manager dialog box shows 
the symbols are removed from the gen-
eral symbol group and moved to 
group1. The general tab is empty.

Note: Click on the group1 tab to verify the 
move

Parameterized Box Example (Continued)
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54. Select the general tab if not already 
selected.

55. Select Import.
The Open dialog box appears.

56. Select box.dwg to highlight it and then 
select Open.
The Import dialog box appears.

57. Select thickbox, xbox, ybox and zbox 
and select Import.
Another set of the original symbols are 
imported and display in the general tab.

58. Select the 4 newly imported symbols.
59. Select Rename.

The Multiple Rename dialog box 
appears.

60. Type _2 in the Append string field and 
verify that Append String to each exist-
ing name is selected.

61. Select OK.
The Symbol Manager dialog box reap-
pears displaying the new symbol names. 

62. Select xbox_2.

Add another set of symbols and append 
the names of the entities with _2.

Symbols can be imported directly from 
DWG files as well as exported symbol 
files.

Also change the values of xbox, ybox and 
zbox to 1/2 of the current values.

Parameterized Box Example (Continued)
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63. Select Edit.
The Expression Editor dialog box 
appears with the current xbox_2 infor-
mation.

64. Highlight the current value in the 
Expression field if not already high-
lighted and type 50 (1/2 of the current 
value of 100).

65. Select OK to close the Expression Editor 
dialog box.
The edited value displays in the Symbol 
Manager.

66. Repeat this process for ybox and zbox, 
changing the current values by 1/2.
The Symbol Manager dialog box reflects 
the changes.

67. Select Done to close the Symbol Man-
ager.

The second box reflects the change in 
size. 

These steps may be repeated for as many boxes that are in the model.

68. Select File > Exit.
A Thermal Desktop/AutoCAD dialog box 
appears asking to save the drawing 
changes.

69. Select Yes.

Exit Thermal Desktop and save as 
prompted.

Parameterized Box Example (Continued)

Figure 20-34: Second Box Edited
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	20 Tutorials
	This chapter presents information and sample problems to explore some of Thermal Desktop’s features. Before beginning the tutorials, AutoCAD®, Thermal Desktop, and SINDA/FLUINT must be installed. Refer to the AutoCAD and Thermal Desktop installati...
	Tutorial files may be found in the \Tutorials\Thermal Desktop subdirectory which is located in the Thermal Desktop installation directory (usually C:\Program Files\Cullimore And Ring\Thermal Desktop). The \Tutorials\Thermal Desktop subdirectory inclu...
	It is recommended that the \Tutorials\Thermal Desktop directory be copied to the user’s own working area before beginning the tutorials. This ensures a copy of the original tutorial files will be available for use by other users at a later time.
	The tutorials attempt to introduce a variety of concepts. Most often there is more than one way to accomplish the “task” of a tutorial. Different techniques are shown in an attempt to expose the user to the variety of features present in Thermal ...
	It is also strongly suggested that each new user take the time to work through each of the tutorials (in this chapter as well as the other tutorial chapters: 21 RadCAD® Tutorials and 22 FloCAD® Tutorials). Although completing the tutorials requires...
	There are eleven tutorials in this chapter, as follows:
	Functionality in the tutorials reflects the most recent version of Thermal Desktop and AutoCAD. Every effort has been made to present the user with the exact system prompts, messages and commands, and dialog boxes the user will see when using Thermal...
	Most of the tutorials are written in a two-column format. The left column provides specific instructions and the right column provides a general description of the steps, provides example views of the graphics area, and sometimes provides background ...
	20.2 Setting Up a Template Drawing
	A template is something that can be used as a pattern for future projects. In Thermal Desktop, a template drawing file can be created and used as a foundation for creating new Thermal Desktop drawings. When creating a template it is important to cons...
	In this tutorial, a template drawing file (file extension DWG) will be created. The template will be used in other tutorials and may be used as a permanent template for use in future thermal analysis tasks. Creating and then using a template drawing ...
	Before beginning a new thermal analysis task, copy the template to a directory chosen to store the work for that particular task or project. Once a copy is made, rename the copied template drawing to a meaningful name related to the thermal task or p...
	The following exercise creates a template file with preferences set to be convenient for working with Thermal Desktop. The user is encouraged to experiment with the available options as a means to discover which settings are compatible to each indivi...
	As experience is gained with Thermal Desktop and some of the advanced options, create a new template file with different parameters such as Units and other property settings as desired. A user may find it useful to have a template for SI units, a tem...

	20.3 Model Browser Example
	This tutorial demonstrates some of the capabilities of Thermal Desktop’s Model Browser. The example model for this tutorial is very simple but the capabilities extend very well to larger models.

	20.4 Circuit Board Conduction Example
	In this exercise, a circuit board will be mounted to an aluminum face. The circuit board will have a chip placed on it.
	Figure 20-7: Aluminum Plate
	Figure 20-8: Board on Aluminum Plate
	Figure 20-9: Chip on Circuit Board
	Figure 20-10: Edge Contactor
	Figure 20-11: Face Contactor
	Figure 20-12: Contactor Markers

	20.5 Beer Can Example
	In this example, a beer can full of beer will be constructed. The initial temperatures will be set to something similar to a refrigerator temperature of 5C. Free convection heat transfer coefficients will be applied to the sides of the can and the to...

	20.6 Conduction and Radiation Using Finite Elements
	In this example, a finite element model will be created with fixed temperatures at either end. The process begins by creating a single quad element. The AutoCAD array command will be used to create a grid of elements. The planar quad elements will be...

	20.7 Mapping Temperatures From a Coarse Thermal Model to a Detailed NASTRAN Model
	This tutorial maps temperatures from a coarse model of a plate with two holes in it to a different mesh of the same model that has much finer detail. This situation is very common when the stress analyst has a very detailed model for a part, but the ...
	CRTech would like to give a special thanks to Jim Braley for providing the sample NASTRAN models for this tutorial.
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	Figure 20-25: Compare Mapper to Model

	20.8 Contactor Example
	This tutorial demonstrates some of the capabilities of Thermal Desktop’s Contactors. The example model is a pipe with circular, plate fins and a small block-shaped sensor. The plate fins will be connected to the pipe by edge contactors that could r...
	Contactors, like contact created with the contact tab in the object edit window, are used to thermally connect two objects. However, contactors provide more functionality than contact such as:
	Figure 20-28: Initial View
	Figure 20-29: Contactors
	Figure 20-30: Contactor markers
	Figure 20-31: Contactors with surface thickness
	Running the model requires a heat load or a fixed boundary temperature (different than the boundary node already defined). The user can add a heat load to the pipe surface or change the pipe nodes to boundary nodes and obtain a solution. The node IDs...
	If the user runs a transient solution, the time step taken by SINDA/FLUINT will likely be very small. This is caused by the large conductance at the base of the fins: G = k*A/L. If the user adds a factor to the coefficient of the fin-to-pipe contacto...


	20.9 Parameterizing for a Common Input
	Sometimes it is common that the same geometry is used over and over in the same model. This geometry can be as simple as a five or six-sided box or can be much more complicated. In this example, a simple five sided-box with centered nodes that has co...
	Figure 20-34: Second Box Edited



